summaryrefslogtreecommitdiff
path: root/dev-python/pgzero/pgzero-1.2.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-16 22:05:01 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-16 22:05:01 +0100
commitcc4618c9ba3d974948ebf340b542d8cb01db2f55 (patch)
tree125ee67bb9e0d548771cf7b61d04bb1f0dc57687 /dev-python/pgzero/pgzero-1.2.1-r1.ebuild
parent677b7ba5c317778df2ad7e70df94b9b7eec4adbc (diff)
gentoo resync : 16.09.2021
Diffstat (limited to 'dev-python/pgzero/pgzero-1.2.1-r1.ebuild')
-rw-r--r--dev-python/pgzero/pgzero-1.2.1-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pgzero/pgzero-1.2.1-r1.ebuild b/dev-python/pgzero/pgzero-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..abeeb71b78ed
--- /dev/null
+++ b/dev-python/pgzero/pgzero-1.2.1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9} )
+
+inherit distutils-r1
+distutils_enable_tests unittest
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="A zero-boilerplate games programming framework based on Pygame"
+HOMEPAGE="https://pygame-zero.readthedocs.io/"
+SRC_URI="https://github.com/lordmauve/${PN}/archive/${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pygame[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ ${RDEPEND}
+ test? (
+ media-libs/sdl2-image[png]
+ media-libs/sdl2-mixer[vorbis]
+ )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+# Allow the tests to pass without real audio or video.
+export SDL_AUDIODRIVER=dummy SDL_VIDEODRIVER=dummy