summaryrefslogtreecommitdiff
path: root/dev-python/pgspecial
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /dev-python/pgspecial
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'dev-python/pgspecial')
-rw-r--r--dev-python/pgspecial/Manifest2
-rw-r--r--dev-python/pgspecial/pgspecial-1.12.1.ebuild25
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pgspecial/Manifest b/dev-python/pgspecial/Manifest
index 48a01c20f5cd..09d7091d1bc4 100644
--- a/dev-python/pgspecial/Manifest
+++ b/dev-python/pgspecial/Manifest
@@ -1,3 +1,5 @@
DIST pgspecial-1.11.10.tar.gz 45560 BLAKE2B f4554eb812fadad984f746e8035a7a91f22480321df920bd15b96239c571c13cdf397ea38ea122f0a73167924a902955a1eb50dc865ba1e4445324358c3e3cef SHA512 452f217055873d3d1acff6b9b5016a3e721bffd4349aaa975aefe3ae1e25ca576f90eab13e7f913ebbfb796ac7b81dd8ed63c8e6d055c2ad7f8fd9d72ca8c21a
+DIST pgspecial-1.12.1.tar.gz 47945 BLAKE2B e189695a3689f76f6fd3afc3b5f7c412dfc0a79fcd2465f8bca29b81de1609e045f0237fcc6b63a75c7df1d9a31d4c04cd8fa227493d6cce4cd6863a4c36cd2a SHA512 d1ef6462ab3d1cf5fe35f0dabc61698d7c2cf7e35b292c3cb540cce4bd613485d7dca53fd549a134209461c31c8144d72d1af1ee8aad5569766d9387b7e10e0b
EBUILD pgspecial-1.11.10.ebuild 636 BLAKE2B 9b93d173d141bad2e04a91026534e9264085e24eefd26f0e43c01c0ca795b57dfe7e93deca8e61bd4d4dd3a0a54873b3c97bbb9c322c8b07d0c92971d36381d9 SHA512 a2e6123f1235fe8af6cbe631d6795b1df9758078396f5d0659afffb6cf83304ba74f752be75143fddc8c10c212ef6703c003fd1d0b7d757749982d71f9c09c32
+EBUILD pgspecial-1.12.1.ebuild 686 BLAKE2B 59bfd0546e6aa127a4511916a7c361f115e2852c9c0706a249289f1dea09ed8db475aaaf4b451bc68d8e900e55dd4f8631339a257dda4a15a3dc8a0e0c76b1fe SHA512 5a52f96408ad5f4454551a89a02a8ff7373a928a11567fc825fd9f74cdd285b0c015c3a97313a99712c0aab9c25771828dc0c69ff80dc61df36f1190bb2110d9
MISC metadata.xml 673 BLAKE2B ce5e774e5131520d65aacf93e9521aa81a6310b37fbeb1254898f2254d080538d5d0ea90cbad6132faa9af3e227845888fa6b6dacede5f09eaae3fac1b7b6cc3 SHA512 e2adf6f8d7f781a42aab4f2269667ca41fcd1615ba2ef13f7f844efb8a2db74287cf6fc2940e00a1fb00a80d62c928ab083b6e45b2dac216addb731c90a3e6ef
diff --git a/dev-python/pgspecial/pgspecial-1.12.1.ebuild b/dev-python/pgspecial/pgspecial-1.12.1.ebuild
new file mode 100644
index 000000000000..f83f61db75dc
--- /dev/null
+++ b/dev-python/pgspecial/pgspecial-1.12.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of PostgreSQL meta commands"
+HOMEPAGE="https://github.com/dbcli/pgspecial"
+SRC_URI="https://github.com/dbcli/pgspecial/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/click-4.1[${PYTHON_USEDEP}]
+ >=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-2.7.4[${PYTHON_USEDEP}]
+ >=dev-python/sqlparse-0.1.19[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+DOCS=( License.txt README.rst changelog.rst )