summaryrefslogtreecommitdiff
path: root/dev-python/pgspecial/pgspecial-1.11.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
commit51af5f0eb4cddbe6aa7953717873691d77aae9ff (patch)
tree1541525274162b033ebbc3ed38abaf335fbbd49a /dev-python/pgspecial/pgspecial-1.11.5.ebuild
parent7014a5a3ea0feffab9701fdd6b64cc7667a985af (diff)
gentoo resync : 11.07.2019
Diffstat (limited to 'dev-python/pgspecial/pgspecial-1.11.5.ebuild')
-rw-r--r--dev-python/pgspecial/pgspecial-1.11.5.ebuild17
1 files changed, 15 insertions, 2 deletions
diff --git a/dev-python/pgspecial/pgspecial-1.11.5.ebuild b/dev-python/pgspecial/pgspecial-1.11.5.ebuild
index edaec9de0592..6318ec7b5292 100644
--- a/dev-python/pgspecial/pgspecial-1.11.5.ebuild
+++ b/dev-python/pgspecial/pgspecial-1.11.5.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
inherit distutils-r1
DESCRIPTION="Python implementation of postgres meta commands"
@@ -13,9 +13,22 @@ SRC_URI="https://github.com/dbcli/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="
>=dev-python/click-4.1[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-2.7.4[${PYTHON_USEDEP}]
>=dev-python/python-sqlparse-0.1.19[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ # tests/test_special.py require local postgres instance
+ pytest -vv tests/test_internal.py || die
+}