summaryrefslogtreecommitdiff
path: root/dev-python/pgmagick/pgmagick-0.6.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pgmagick/pgmagick-0.6.7.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pgmagick/pgmagick-0.6.7.ebuild')
-rw-r--r--dev-python/pgmagick/pgmagick-0.6.7.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pgmagick/pgmagick-0.6.7.ebuild b/dev-python/pgmagick/pgmagick-0.6.7.ebuild
new file mode 100644
index 000000000000..5aa0828dee6b
--- /dev/null
+++ b/dev-python/pgmagick/pgmagick-0.6.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Yet another boost.python based wrapper for GraphicsMagick"
+HOMEPAGE="https://pypi.org/project/pgmagick/ https://bitbucket.org/hhatto/pgmagick/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ media-gfx/graphicsmagick:=[cxx]
+ dev-libs/boost:=[python,${PYTHON_USEDEP}]"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( media-fonts/corefonts )"
+
+python_test() {
+ cd test || die
+
+ local t
+ for t in test_*.py; do
+ "${EPYTHON}" "${t}" || die "test ${t} failed under ${EPYTHON}"
+ done
+ # As long as the order of python impls is not changed, this will suffice
+}