summaryrefslogtreecommitdiff
path: root/dev-python/pexpect/pexpect-4.8.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-07 01:33:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-07 01:33:16 +0100
commitc8fd0d84af0bfd1949542adc2cbb735b1d28f9ed (patch)
tree3ee550255947da075650f1a551dcc278f9a1b7f8 /dev-python/pexpect/pexpect-4.8.0-r1.ebuild
parenta978c074e4272bb901fbe4a10de0a7b2af574f17 (diff)
gentoo resync : 07.05.2021
Diffstat (limited to 'dev-python/pexpect/pexpect-4.8.0-r1.ebuild')
-rw-r--r--dev-python/pexpect/pexpect-4.8.0-r1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-python/pexpect/pexpect-4.8.0-r1.ebuild b/dev-python/pexpect/pexpect-4.8.0-r1.ebuild
index cbcceab75200..7baa9ab2af81 100644
--- a/dev-python/pexpect/pexpect-4.8.0-r1.ebuild
+++ b/dev-python/pexpect/pexpect-4.8.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
PYTHON_REQ_USE="threads(+)"
DISTUTILS_USE_SETUPTOOLS=no
@@ -32,6 +32,13 @@ python_compile_all() {
use doc && emake -C doc html
}
+src_test() {
+ # workaround new readline defaults
+ echo "set enable-bracketed-paste off" > "${T}"/inputrc || die
+ local -x INPUTRC="${T}"/inputrc
+ distutils-r1_src_test
+}
+
python_install() {
distutils-r1_python_install
if ! python_is_python3; then