summaryrefslogtreecommitdiff
path: root/dev-python/peewee/peewee-3.16.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-14 18:13:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-14 18:13:29 +0100
commit85dc262ae9ec9413f8172a2a8442d6d9134d02f4 (patch)
tree81768a8b154fded73a17e9475cebc90d79fd4720 /dev-python/peewee/peewee-3.16.3.ebuild
parentb6323af2602e6a5cd4920d4af06b5c2f3949b9d0 (diff)
gentoo auto-resync : 14:08:2023 - 18:13:29
Diffstat (limited to 'dev-python/peewee/peewee-3.16.3.ebuild')
-rw-r--r--dev-python/peewee/peewee-3.16.3.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/peewee/peewee-3.16.3.ebuild b/dev-python/peewee/peewee-3.16.3.ebuild
new file mode 100644
index 000000000000..d0a5ef1e5387
--- /dev/null
+++ b/dev-python/peewee/peewee-3.16.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="Small Python ORM"
+HOMEPAGE="
+ https://github.com/coleifer/peewee/
+ https://pypi.org/project/peewee/
+"
+SRC_URI="
+ https://github.com/coleifer/peewee/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="examples +native-extensions test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ native-extensions? ( dev-db/sqlite:3= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs
+
+src_compile() {
+ if ! use native-extensions; then
+ local -x NO_SQLITE=1
+ fi
+
+ distutils-r1_src_compile
+}
+
+python_test() {
+ "${EPYTHON}" runtests.py -v 2 || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && DOCS=( examples/ )
+ distutils-r1_python_install_all
+}