summaryrefslogtreecommitdiff
path: root/dev-python/pebble/pebble-5.0.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-26 07:37:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-26 07:37:53 +0000
commit058e62d5e60f6fc7f010f73f4c1546e979344a0b (patch)
treed4cc27f68681c52e6387b26f0f9daf36979ab36b /dev-python/pebble/pebble-5.0.6.ebuild
parent15bb7733ddb1f16a0e3936969282ecc42419829a (diff)
gentoo auto-resync : 26:12:2023 - 07:37:53
Diffstat (limited to 'dev-python/pebble/pebble-5.0.6.ebuild')
-rw-r--r--dev-python/pebble/pebble-5.0.6.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pebble/pebble-5.0.6.ebuild b/dev-python/pebble/pebble-5.0.6.ebuild
new file mode 100644
index 000000000000..570400970374
--- /dev/null
+++ b/dev-python/pebble/pebble-5.0.6.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN^}
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Threading and multiprocessing eye-candy"
+HOMEPAGE="
+ https://pebble.readthedocs.io/
+ https://github.com/noxdafox/pebble/
+ https://pypi.org/project/Pebble/
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest