summaryrefslogtreecommitdiff
path: root/dev-python/pebble/pebble-5.0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-22 11:17:57 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-22 11:17:57 +0000
commit77b74be093bdf4a0ed4121acc3f8e229103cf004 (patch)
tree63d35b3e7246dd3ae3c181b1e47212a89a5f8d2c /dev-python/pebble/pebble-5.0.4.ebuild
parent734d2dac3e96161f025c33aa2d518d798cd06580 (diff)
gentoo auto-resync : 22:11:2023 - 11:17:57
Diffstat (limited to 'dev-python/pebble/pebble-5.0.4.ebuild')
-rw-r--r--dev-python/pebble/pebble-5.0.4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pebble/pebble-5.0.4.ebuild b/dev-python/pebble/pebble-5.0.4.ebuild
new file mode 100644
index 000000000000..570400970374
--- /dev/null
+++ b/dev-python/pebble/pebble-5.0.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN^}
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Threading and multiprocessing eye-candy"
+HOMEPAGE="
+ https://pebble.readthedocs.io/
+ https://github.com/noxdafox/pebble/
+ https://pypi.org/project/Pebble/
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest