summaryrefslogtreecommitdiff
path: root/dev-python/pebble/pebble-4.6.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
commit7218e1b46bceac05841e90472501742d905fb3fc (patch)
tree56fae051db521b8fce8014cbc8b11484885b14b3 /dev-python/pebble/pebble-4.6.1.ebuild
parent6d691ad5b6239929063441bbd14c489e92e7396e (diff)
gentoo resync : 12.03.2021
Diffstat (limited to 'dev-python/pebble/pebble-4.6.1.ebuild')
-rw-r--r--dev-python/pebble/pebble-4.6.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/pebble/pebble-4.6.1.ebuild b/dev-python/pebble/pebble-4.6.1.ebuild
new file mode 100644
index 000000000000..7ef364dc27df
--- /dev/null
+++ b/dev-python/pebble/pebble-4.6.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+MY_P=${P^}
+DESCRIPTION="Threading and multiprocessing eye-candy"
+HOMEPAGE="
+ https://pypi.org/project/Pebble/
+ https://pebble.readthedocs.io/
+ https://github.com/noxdafox/pebble"
+SRC_URI="mirror://pypi/${MY_P::1}/${PN^}/${MY_P}.tar.gz"
+S=${WORKDIR}/${P^}
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+distutils_enable_tests pytest