summaryrefslogtreecommitdiff
path: root/dev-python/pdm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-21 00:05:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-21 00:05:36 +0100
commitbfd63d5b0e96ad32e0d0a8fe15512b6a9ac6fc9e (patch)
tree4d1f8172a8137960573865b4a5ac8b7846d281df /dev-python/pdm
parent77b275a53383b07b154caa09feb6f4961b206638 (diff)
gentoo auto-resync : 21:05:2024 - 00:05:35
Diffstat (limited to 'dev-python/pdm')
-rw-r--r--dev-python/pdm/Manifest2
-rw-r--r--dev-python/pdm/pdm-2.15.3.ebuild117
2 files changed, 119 insertions, 0 deletions
diff --git a/dev-python/pdm/Manifest b/dev-python/pdm/Manifest
index 7216244ee108..b403228af4b9 100644
--- a/dev-python/pdm/Manifest
+++ b/dev-python/pdm/Manifest
@@ -1,5 +1,7 @@
DIST pdm-2.15.1.tar.gz 2612654 BLAKE2B 043f4d3ca54cd277f8c6fdd35fb423497eb7b172e085df5bffdd21d9ff5103b112a659fb61c342991211c9630333c713272ba43c65eff52c8dd6b88e4f81e563 SHA512 b6a1028767f154a5a594cd8523d31cec16df46e1c63bb73541a516877879480ffc6916316289f67cda0ae5e4740cab448b029a694743b9816604b2eb175a8722
DIST pdm-2.15.2.tar.gz 2613423 BLAKE2B 91c2d7137223ef143a3a3cb51915ab3b02ef7a6f97798b5a75af05b90c909ade0e1d0b52e6e011956bfb925e76e569dc65bc3258c4397013254c6c5483f1e0ec SHA512 dc58b46fc6a3e8c2ee664b70d7c2112fad3fce5445c390393c4a44230a5e1793baad46baa5b0581fcea49d414a04b0c5dce361b489d82daa4f61f511704c8080
+DIST pdm-2.15.3.tar.gz 2613644 BLAKE2B bc37f4417176a8540fff32e4329da7e6162e9f85379ff6965272315ee691dc38c8f8d1857988e89688d6498433f89c02520d0e498408fb0b9f1924d1ca961ac0 SHA512 d411e695fff4ca8f35cfbce2c8eb1434a0775bc028f852782fc445b18c5f7774d82710d7604a7641bd07ae2a7cd2fd082128caadd0cd7a472cf6a58754071385
EBUILD pdm-2.15.1.ebuild 5006 BLAKE2B c66c1b7a281b37c88b292ca642f10ec5a951f27e9fbd3bb3a502dcedf9dcc3abfe87aeb7a66396ae5b815eff2a541438ac8e5a450554cdb94023768887ff6e29 SHA512 e55e9dda4bd9c8c15c68449bc9dab28b8e1533fe5fbf783a31295bf0b394bee3d53f4969ee3a63c8e7ca0986c0134c7f8e534f5bdac058605971fdba772e3617
EBUILD pdm-2.15.2.ebuild 5013 BLAKE2B 3e4724269ce8d786119f1d40207a462417561dba310287fe7065546a7a2a03b9feff56b3b260e0fc12a04977cf4cab54db33a222f6395930b494a7581749e336 SHA512 90ea127f5eb738d0d3a859b5910230848694f31411a4d431ad470100ebeeb16a24440b1c54d80c45c5efb7ccbe04b69c6e9f86aeadca671d121c5fb864e4185d
+EBUILD pdm-2.15.3.ebuild 5013 BLAKE2B 3e4724269ce8d786119f1d40207a462417561dba310287fe7065546a7a2a03b9feff56b3b260e0fc12a04977cf4cab54db33a222f6395930b494a7581749e336 SHA512 90ea127f5eb738d0d3a859b5910230848694f31411a4d431ad470100ebeeb16a24440b1c54d80c45c5efb7ccbe04b69c6e9f86aeadca671d121c5fb864e4185d
MISC metadata.xml 474 BLAKE2B c1471e124a955920e30f73dfa43a87999c30c2bb9615590f601befcc07f7d939ec68908e67c7345fca4cb0f0524d33507aeac9936fa30d449d1dde17094048d3 SHA512 a07256061dda5a8cf8b0e15205ac36651a4e5b594fdedbfe16d1d3264e1ac42847d1dc222d2857232ac5206d67feda432751695d85d0c4c7b03fd7228db8b1ab
diff --git a/dev-python/pdm/pdm-2.15.3.ebuild b/dev-python/pdm/pdm-2.15.3.ebuild
new file mode 100644
index 000000000000..5daeb246e11a
--- /dev/null
+++ b/dev-python/pdm/pdm-2.15.3.ebuild
@@ -0,0 +1,117 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python package and dependency manager supporting the latest PEP standards"
+HOMEPAGE="
+ https://pdm-project.org/
+ https://github.com/pdm-project/pdm/
+ https://pypi.org/project/pdm/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ dev-python/blinker[${PYTHON_USEDEP}]
+ >=dev-python/dep-logic-0.2.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/platformdirs[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ dev-python/truststore[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/hishel[${PYTHON_USEDEP}]
+ dev-python/pbs-installer[${PYTHON_USEDEP}]
+ dev-python/pyproject-hooks[${PYTHON_USEDEP}]
+ >=dev-python/unearth-0.15.0[${PYTHON_USEDEP}]
+ <dev-python/findpython-1[${PYTHON_USEDEP}]
+ >=dev-python/findpython-0.6.0[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+ dev-python/shellingham[${PYTHON_USEDEP}]
+ dev-python/python-dotenv[${PYTHON_USEDEP}]
+ >=dev-python/resolvelib-1.0.1[${PYTHON_USEDEP}]
+ dev-python/installer[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet
+ 'tests/cli/test_build.py::test_build_with_no_isolation[False]'
+ tests/test_project.py::test_access_index_with_auth
+ "tests/test_project.py::test_find_interpreters_with_PDM_IGNORE_ACTIVE_VENV[True]"
+ tests/cli/test_others.py::test_build_distributions
+ 'tests/models/test_candidates.py::test_expand_project_root_in_url[demo @ file:///${PROJECT_ROOT}/tests/fixtures/artifacts/demo-0.0.1.tar.gz]'
+ 'tests/models/test_candidates.py::test_expand_project_root_in_url[-e file:///${PROJECT_ROOT}/tests/fixtures/projects/demo-#-with-hash#egg=demo]'
+ tests/models/test_candidates.py::test_find_candidates_from_find_links
+ tests/cli/test_build.py::test_build_single_module
+ tests/cli/test_build.py::test_build_single_module_with_readme
+ tests/cli/test_build.py::test_build_package
+ tests/cli/test_build.py::test_build_src_package
+ tests/cli/test_build.py::test_build_package_include
+ tests/cli/test_build.py::test_build_src_package_by_include
+ tests/cli/test_build.py::test_build_with_config_settings
+ tests/cli/test_build.py::test_cli_build_with_config_settings
+ tests/cli/test_build.py::test_build_ignoring_pip_environment
+ tests/cli/test_others.py::test_show_self_package
+ tests/cli/test_publish.py::test_publish_and_build_in_one_run
+ "tests/cli/test_hooks.py::test_hooks[build]"
+ "tests/cli/test_hooks.py::test_hooks[publish]"
+ "tests/cli/test_hooks.py::test_skip_option_from_signal[build-pre_build]"
+ "tests/cli/test_hooks.py::test_skip_option_from_signal[build-post_build]"
+ "tests/cli/test_hooks.py::test_skip_option_from_signal[publish-pre_publish]"
+ "tests/cli/test_hooks.py::test_skip_option_from_signal[publish-pre_build]"
+ "tests/cli/test_hooks.py::test_skip_option_from_signal[publish-post_build]"
+ "tests/cli/test_hooks.py::test_skip_option_from_signal[publish-post_publish]"
+ "tests/cli/test_hooks.py::test_skip_all_option_from_signal[:all-build]"
+ "tests/cli/test_hooks.py::test_skip_all_option_from_signal[:all-publish]"
+ "tests/cli/test_hooks.py::test_skip_all_option_from_signal[:pre,:post-build]"
+ "tests/cli/test_hooks.py::test_skip_all_option_from_signal[:pre,:post-publish]"
+ "tests/cli/test_hooks.py::test_skip_pre_post_option_from_signal[pre-build]"
+ "tests/cli/test_hooks.py::test_skip_pre_post_option_from_signal[pre-publish]"
+ "tests/cli/test_hooks.py::test_skip_pre_post_option_from_signal[post-build]"
+ "tests/cli/test_hooks.py::test_skip_pre_post_option_from_signal[post-publish]"
+ "tests/cli/test_venv.py::test_conda_backend_create[True]"
+ "tests/cli/test_venv.py::test_conda_backend_create[False]"
+ tests/cli/test_lock.py::test_lock_all_with_excluded_groups
+ # hangs on interactive keyring prompts
+ tests/cli/test_config.py::test_repository_overwrite_default
+ tests/cli/test_config.py::test_hide_password_in_output_repository
+ tests/cli/test_config.py::test_hide_password_in_output_pypi
+ # junk output, sigh
+ tests/cli/test_others.py::test_info_command_json
+ # why does it try to use python 2.7?!
+ tests/cli/test_run.py::test_import_another_sitecustomize
+ # fails in tinderbox (bug #928964)
+ tests/test_project.py::test_project_packages_path
+ )
+ [[ ${EPYTHON} != python3.10 ]] && EPYTEST_DESELECT+=(
+ # test seems hardcoded to 3.10
+ tests/test_project.py::test_project_packages_path
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -m "not network and not integration and not path" \
+ -p pytest_mock
+}