summaryrefslogtreecommitdiff
path: root/dev-python/pdm-pep517
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-25 09:51:58 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-25 09:51:58 +0000
commitbaeb826318951e5c82b18c1e9ee120ac5dcf0b94 (patch)
tree7154de118466f928d847a0659795c3f84c116096 /dev-python/pdm-pep517
parent1e17db840dfd2f8b2b43a0a385c106812ebcfea9 (diff)
gentoo auto-resync : 25:02:2023 - 09:51:58
Diffstat (limited to 'dev-python/pdm-pep517')
-rw-r--r--dev-python/pdm-pep517/Manifest2
-rw-r--r--dev-python/pdm-pep517/pdm-pep517-1.0.6-r1.ebuild60
2 files changed, 0 insertions, 62 deletions
diff --git a/dev-python/pdm-pep517/Manifest b/dev-python/pdm-pep517/Manifest
index 7b2b98e7f6f4..268311284894 100644
--- a/dev-python/pdm-pep517/Manifest
+++ b/dev-python/pdm-pep517/Manifest
@@ -1,5 +1,3 @@
-DIST pdm-pep517-1.0.6.gh.tar.gz 315755 BLAKE2B 7b221d9ddc9683521e901177cafd2ffd2908af4acbe083b4a7d6525a81ece64d3768331135451d45ffc5c40c67c8c72802d75d52fdf85fa89a13f30110436a13 SHA512 5aeef3179d508d2acaedf4b99df41e64b26537120e586a01870651d2b379e2e5a1bf42934ee28a4b285cb83fe10ead073408b6b7d022ca1f55653533d12a2da1
DIST pdm-pep517-1.1.2.gh.tar.gz 231983 BLAKE2B b2225da24f52d4d2c1a903db57f000a1fb2ba8435083d956ff740d272ee2fa8f00cf001673e32800fc0437ae2d1016cac661fda24f8b5f34c83a342fd3e8c353 SHA512 8f6140492ef8323044f01887895e6664019092f964e1fae3a829bcefb3d5d9c9223ef163183899681270f95b4a3a517951b7e44629ec3f37598c04ccbb221cac
-EBUILD pdm-pep517-1.0.6-r1.ebuild 1399 BLAKE2B aeb00416ccf9946c72df5580ec7090872495a2664e68e7026ecd5c34716fe22ecc390bd610b55d40163b2202678f511f07136010b4df221a1fa55fca834b751b SHA512 68b90245ffb1c213b0f2f07a4142d877f49192d443f8d54c4a57baac596dfeeb4644e9ebc4a3ebc198c9de3d662343bd6153b7150fe5cad885e37f562088136d
EBUILD pdm-pep517-1.1.2-r1.ebuild 1499 BLAKE2B 45092f6ce97e05b56dbc7642b4d5b06c647fce542ac44b8b4e52b75aa682910657640c14bc1109c198224c68a7cff907bf8af0f2b5683721db487834635fd579 SHA512 1396db9ce8e75e56635b0c29ef2948d041b4b0e7781cbe05c392527468ef8ba207e438064b75500009c757922ede5e47b35182ee2520b46a2e7d02debd5d39f6
MISC metadata.xml 401 BLAKE2B bd202e8cb137f8c6d74d4706e9e4aed7fc8a10825f68d8fec1814c26a58a2ae14208e1256a6826209019b6066f9b96d94a108e1a48c368261886357b7c20893b SHA512 dedab34ff5a645536807de7c3c616e11846d22c7aebf8446d88fb8c3a5c0edc6e97c2a3b25874ab7413b9b6ac6c0734df54e252ee1c55bc1b698883aa1f1552b
diff --git a/dev-python/pdm-pep517/pdm-pep517-1.0.6-r1.ebuild b/dev-python/pdm-pep517/pdm-pep517-1.0.6-r1.ebuild
deleted file mode 100644
index 64a5235e005f..000000000000
--- a/dev-python/pdm-pep517/pdm-pep517-1.0.6-r1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=standalone
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A PEP 517 backend for PDM that supports PEP 621 metadata"
-HOMEPAGE="
- https://pypi.org/project/pdm-pep517/
- https://github.com/pdm-project/pdm-pep517/
-"
-SRC_URI="
- https://github.com/pdm-project/pdm-pep517/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~riscv x86"
-
-RDEPEND="
- >=dev-python/cerberus-1.3.4[${PYTHON_USEDEP}]
- dev-python/license-expression[${PYTHON_USEDEP}]
- <dev-python/packaging-22[${PYTHON_USEDEP}]
- >=dev-python/packaging-21.0[${PYTHON_USEDEP}]
- >=dev-python/tomli-2[${PYTHON_USEDEP}]
- dev-python/tomli-w[${PYTHON_USEDEP}]
-"
-BDEPEND="
- ${RDEPEND}
- test? (
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-vcs/git
- )
-"
-# setuptools are used to build C extensions
-RDEPEND+="
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- rm -r pdm/pep517/_vendor || die
- find -name '*.py' -exec sed \
- -e 's:from pdm\.pep517\._vendor\.:from :' \
- -e 's:from pdm\.pep517\._vendor ::' \
- -i {} + || die
- distutils-r1_src_prepare
-}
-
-src_test() {
- git config --global user.email "test@example.com" || die
- git config --global user.name "Test User" || die
- distutils-r1_src_test
-}