summaryrefslogtreecommitdiff
path: root/dev-python/pdm-pep517/pdm-pep517-1.0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-24 09:51:43 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-24 09:51:43 +0100
commitbb17db5f98333b3c74b4194d1c1136144f693add (patch)
tree65d7446b00fbeb21e2dd8dc4c106526dd4a8fb7d /dev-python/pdm-pep517/pdm-pep517-1.0.5.ebuild
parent1e9275d80771f014d7754407ca8ab9d7c43247b0 (diff)
gentoo auto-resync : 24:10:2022 - 09:51:42
Diffstat (limited to 'dev-python/pdm-pep517/pdm-pep517-1.0.5.ebuild')
-rw-r--r--dev-python/pdm-pep517/pdm-pep517-1.0.5.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/pdm-pep517/pdm-pep517-1.0.5.ebuild b/dev-python/pdm-pep517/pdm-pep517-1.0.5.ebuild
new file mode 100644
index 000000000000..1d4b03ff9e34
--- /dev/null
+++ b/dev-python/pdm-pep517/pdm-pep517-1.0.5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A PEP 517 backend for PDM that supports PEP 621 metadata"
+HOMEPAGE="
+ https://pypi.org/project/pdm-pep517/
+ https://github.com/pdm-project/pdm-pep517/
+"
+SRC_URI="
+ https://github.com/pdm-project/pdm-pep517/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/cerberus-1.3.4[${PYTHON_USEDEP}]
+ dev-python/license-expression[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.0[${PYTHON_USEDEP}]
+ >=dev-python/tomli-2[${PYTHON_USEDEP}]
+ dev-python/tomli-w[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-vcs/git
+ )
+"
+# setuptools are used to build C extensions
+RDEPEND+="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ rm -r pdm/pep517/_vendor || die
+ find -name '*.py' -exec sed \
+ -e 's:from pdm\.pep517\._vendor\.:from :' \
+ -e 's:from pdm\.pep517\._vendor ::' \
+ -i {} + || die
+ distutils-r1_src_prepare
+}
+
+src_test() {
+ git config --global user.email "test@example.com" || die
+ git config --global user.name "Test User" || die
+ distutils-r1_src_test
+}