summaryrefslogtreecommitdiff
path: root/dev-python/pbr/pbr-5.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-python/pbr/pbr-5.1.1.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-python/pbr/pbr-5.1.1.ebuild')
-rw-r--r--dev-python/pbr/pbr-5.1.1.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-python/pbr/pbr-5.1.1.ebuild b/dev-python/pbr/pbr-5.1.1.ebuild
index 956f9fc47cda..91144ad7969c 100644
--- a/dev-python/pbr/pbr-5.1.1.ebuild
+++ b/dev-python/pbr/pbr-5.1.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
@@ -37,7 +37,9 @@ DEPEND="
>=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
>=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
>=dev-python/virtualenv-14.0.6[${PYTHON_USEDEP}]
- >=dev-python/stestr-2.1.0[$(python_gen_usedep python{2_7,3_5,3_6})]
+ $(python_gen_cond_dep '
+ >=dev-python/stestr-2.1.0[${PYTHON_USEDEP}]
+ ' python{2_7,3_5,3_6})
>=dev-python/coverage-4.0[${PYTHON_USEDEP}]
!~dev-python/coverage-4.4[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]