summaryrefslogtreecommitdiff
path: root/dev-python/pbr/pbr-4.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-python/pbr/pbr-4.1.1.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-python/pbr/pbr-4.1.1.ebuild')
-rw-r--r--dev-python/pbr/pbr-4.1.1.ebuild34
1 files changed, 21 insertions, 13 deletions
diff --git a/dev-python/pbr/pbr-4.1.1.ebuild b/dev-python/pbr/pbr-4.1.1.ebuild
index 1f13d6c70ecd..f9fbfd117e8e 100644
--- a/dev-python/pbr/pbr-4.1.1.ebuild
+++ b/dev-python/pbr/pbr-4.1.1.ebuild
@@ -24,19 +24,21 @@ RESTRICT="!test? ( test )"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
- >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
- !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
- >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
- >=dev-python/testresources-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
- >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/virtualenv-14.0.6[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- dev-vcs/git
+ $(python_gen_cond_dep '
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testresources-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-14.0.6[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ dev-vcs/git
+ ' -3)
)"
PDEPEND=""
@@ -62,6 +64,12 @@ python_prepare_all() {
}
python_test() {
+ if ! python_is_python3; then
+ ewarn "Skipping tests on ${EPYTHON} to unblock circular deps."
+ ewarn "Please run tests manually."
+ return
+ fi
+
distutils_install_for_testing
rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPTYHON}"