summaryrefslogtreecommitdiff
path: root/dev-python/pbr/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-06 23:58:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-06 23:58:42 +0100
commit992d51a146d493f8dd5d710e033427d323b9c739 (patch)
tree8463bd925b241d603b8a754ce50fd81e46ed7b86 /dev-python/pbr/files
parent8368c614e6a1232f34a14cd6495cf2f68933030d (diff)
gentoo auto-resync : 06:10:2023 - 23:58:42
Diffstat (limited to 'dev-python/pbr/files')
-rw-r--r--dev-python/pbr/files/pbr-5.11.1-sphinx-tests.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pbr/files/pbr-5.11.1-sphinx-tests.patch b/dev-python/pbr/files/pbr-5.11.1-sphinx-tests.patch
new file mode 100644
index 000000000000..0cdb1fe48ec3
--- /dev/null
+++ b/dev-python/pbr/files/pbr-5.11.1-sphinx-tests.patch
@@ -0,0 +1,32 @@
+diff --git a/pbr/tests/test_core.py b/pbr/tests/test_core.py
+index edb7c7b..1730c4f 100644
+--- a/pbr/tests/test_core.py
++++ b/pbr/tests/test_core.py
+@@ -78,6 +78,7 @@ class TestCore(base.BaseTestCase):
+ assert stdout == 'packaging, distutils, setuptools'
+
+ def test_setup_py_build_sphinx(self):
++ self.skipTest("broken with sphinx-7, obsolete")
+ stdout, _, return_code = self.run_setup('build_sphinx')
+ self.assertEqual(0, return_code)
+
+diff --git a/pbr/tests/test_setup.py b/pbr/tests/test_setup.py
+index 4307708..ea5bd3d 100644
+--- a/pbr/tests/test_setup.py
++++ b/pbr/tests/test_setup.py
+@@ -231,6 +231,7 @@ class BaseSphinxTest(base.BaseTestCase):
+
+ def setUp(self):
+ super(BaseSphinxTest, self).setUp()
++ self.skipTest("broken with sphinx-7, obsolete")
+
+ # setup_command requires the Sphinx instance to have some
+ # attributes that aren't set normally with the way we use the
+@@ -379,6 +380,7 @@ class APIAutoDocTest(base.BaseTestCase):
+
+ def setUp(self):
+ super(APIAutoDocTest, self).setUp()
++ self.skipTest("broken with sphinx-7, obsolete")
+
+ # setup_command requires the Sphinx instance to have some
+ # attributes that aren't set normally with the way we use the