summaryrefslogtreecommitdiff
path: root/dev-python/patiencediff/patiencediff-0.2.13.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /dev-python/patiencediff/patiencediff-0.2.13.ebuild
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'dev-python/patiencediff/patiencediff-0.2.13.ebuild')
-rw-r--r--dev-python/patiencediff/patiencediff-0.2.13.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/patiencediff/patiencediff-0.2.13.ebuild b/dev-python/patiencediff/patiencediff-0.2.13.ebuild
new file mode 100644
index 000000000000..c50ac00c18d5
--- /dev/null
+++ b/dev-python/patiencediff/patiencediff-0.2.13.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python implementation of the patiencediff algorithm"
+HOMEPAGE="
+ https://github.com/breezy-team/patiencediff/
+ https://pypi.org/project/patiencediff/
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests unittest
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ eunittest
+}