summaryrefslogtreecommitdiff
path: root/dev-python/pathspec/pathspec-0.10.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-10 09:20:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-10 09:20:14 +0000
commitc15acf374d4b25ba5afcb52435da6090f2d98a20 (patch)
treef3be21d2a949edee4af8b18e1d9ae7501ae5f186 /dev-python/pathspec/pathspec-0.10.3.ebuild
parentcaf79cb4f7c4d5f7cce488d8f50dfb98ddbd09ab (diff)
gentoo auto-resync : 10:12:2022 - 09:20:14
Diffstat (limited to 'dev-python/pathspec/pathspec-0.10.3.ebuild')
-rw-r--r--dev-python/pathspec/pathspec-0.10.3.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/pathspec/pathspec-0.10.3.ebuild b/dev-python/pathspec/pathspec-0.10.3.ebuild
new file mode 100644
index 000000000000..a69ad1fd06dd
--- /dev/null
+++ b/dev-python/pathspec/pathspec-0.10.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Utility library for gitignore style pattern matching of file paths"
+HOMEPAGE="
+ https://github.com/cpburnz/python-pathspec/
+ https://pypi.org/project/pathspec/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests unittest