summaryrefslogtreecommitdiff
path: root/dev-python/pathable
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-02 22:17:13 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-02 22:17:13 +0100
commitec321939a77843497c860196ea06d7776d94b755 (patch)
tree426c3b59f57bfb684b461e65c4416048b369b4ce /dev-python/pathable
parent2982504d287f7f91eade76902f11e691f8181071 (diff)
gentoo auto-resync : 02:09:2022 - 22:17:13
Diffstat (limited to 'dev-python/pathable')
-rw-r--r--dev-python/pathable/Manifest3
-rw-r--r--dev-python/pathable/metadata.xml13
-rw-r--r--dev-python/pathable/pathable-0.4.3.ebuild28
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pathable/Manifest b/dev-python/pathable/Manifest
new file mode 100644
index 000000000000..fcbb210c0123
--- /dev/null
+++ b/dev-python/pathable/Manifest
@@ -0,0 +1,3 @@
+DIST pathable-0.4.3.gh.tar.gz 21412 BLAKE2B 6f62cd879723ff14c2fd7100c9ce7135d200fe04afb473180518ed2e80c5bc5836f82334b1dbbbc8fa80b428fa33db1a8ffafcd8b756cc00a24a809094f61dd2 SHA512 5481ba1e6f4ab4318b9a7bd1d1ddd152f715b001bc7edd1b1221501da1a95578ee6601ce4ce0bdb98773c7954212687d249418e69acef1b350fc5d6cb188dbfc
+EBUILD pathable-0.4.3.ebuild 587 BLAKE2B f7c4506617fdf81ac9c9aa65bee2c33bd88048bb356de96e763f77605cd2aa0d40b3617a6d149d7ca8f4fa19ab5212a19c1fef7abe63acc9dd8d90f15d56a4e2 SHA512 e9c9b40780db1cfcfd471ffb3a174cb3a239785fba0ad1e0963cea680cee5579c1d7b5dc4606c9bb78092bfba5b35160b8b100acd9e4fa2da04ec97e5a27d379
+MISC metadata.xml 390 BLAKE2B d4bad265ee5a0e0a772a84e3b996be1e761ba72cab98f588a18db6cd31ba22a52f89569eda649210aa7d46af66f057e04c5cc1cc1147480255c502d274b3c098 SHA512 56c9403cf21c59f0b13837e1ab2ac87c6c350dd6737561c917d8787c083510a4cebd4a2d752a21ec366b9cf924c4e4cb8122a0e84d99fa0f37b78779e13d0e09
diff --git a/dev-python/pathable/metadata.xml b/dev-python/pathable/metadata.xml
new file mode 100644
index 000000000000..8ce0babd047a
--- /dev/null
+++ b/dev-python/pathable/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">pathable</remote-id>
+ <remote-id type="github">p1c2u/pathable</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pathable/pathable-0.4.3.ebuild b/dev-python/pathable/pathable-0.4.3.ebuild
new file mode 100644
index 000000000000..a1b582e5e643
--- /dev/null
+++ b/dev-python/pathable/pathable-0.4.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="Object-oriented paths"
+HOMEPAGE="
+ https://pypi.org/project/pathable/
+ https://github.com/p1c2u/pathable
+"
+SRC_URI="
+ https://github.com/p1c2u/pathable/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/--cov/d' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}