summaryrefslogtreecommitdiff
path: root/dev-python/path
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-01 20:53:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-01 20:53:45 +0000
commit896d6a8a88861c42b5d531a2f147c8a29a149bd8 (patch)
tree081fe10813721a96088dca6b54bc35bcac18afc6 /dev-python/path
parent3059f20995d5ac642b7b4a38d538fdf1cc45d90d (diff)
gentoo auto-resync : 01:12:2022 - 20:53:45
Diffstat (limited to 'dev-python/path')
-rw-r--r--dev-python/path/Manifest2
-rw-r--r--dev-python/path/path-16.6.0.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/path/Manifest b/dev-python/path/Manifest
index 9c47958e84a3..6cd7f4d99917 100644
--- a/dev-python/path/Manifest
+++ b/dev-python/path/Manifest
@@ -1,3 +1,5 @@
DIST path-16.5.0.gh.tar.gz 44286 BLAKE2B 1d96b0003c562044c1c2ba5eba7a525d5503bd9a58ec1f9611d74e9d52581f646447d3d754809b49b4418c18de9fbfd5de34077fe9edb1c4b3d3fd49f9c2af19 SHA512 0b9b306b2b5cce1e51d65a7555e54770e19a3d4796dbaf2d617bbe8282c771e3d7975112e443462e9b43bafc533d6dc61bedb8608b0d93cc0d1febec995d1780
+DIST path-16.6.0.gh.tar.gz 45238 BLAKE2B f1fa3a23ba19f623ca276496c1fa7351ea02858710f2dddbf5f4d96cf2c9f8fc3325c74a56f1b4dec809e28e927f2c8adab913eed9d8893016e0fd3d0b3a662d SHA512 4d7772b7eb7017bee78f95f30f6286b14750d6d8edbf5f58617ede12bd664f1b893921b89bb64f797e1d2eb7e67e361d8f1e01618fee26d64a5b879a3854aead
EBUILD path-16.5.0.ebuild 912 BLAKE2B e5f67f0ab168f5ed17d15e6a072e47fc922dabef4c9b834e9b32d3bc29da62066c4e7341f5e96732b458636144eae0b6e4c5c3a93a503496257ff0b7d7fd4ffe SHA512 d7db2839493d6a642d8242fe5a8a69d22031b192b05896deef3abef68d91118e48b023ff277ced94149e10237c9fd18588631f8c4a68222c570192161d45fc60
+EBUILD path-16.6.0.ebuild 920 BLAKE2B bbfc51ae3e83c511322a9123e2ab974970c697d259c1c05f3a8393548b367dfc78fbd43f63edda4942d62e6ce07d315281f353676e796cdf1c1e5f7c61a85593 SHA512 fcdc1d9f63008a8437d2b6977f426a082cd242918faf471897979f006586f65dd4bbd4741c46db74bef980cbcbd8780a27282850148d522ee18facbcb6c17289
MISC metadata.xml 383 BLAKE2B 30f12776bf4f9c1995774d7dc68cd8d9a85b74d514e8239ba76af336e6b08979e496ddaffce999bf0a3557f88ced148335024628b61f765b5bd08bf90b453c5a SHA512 aaceff1caa2714c0b8b3f7373c8721358e63833cfac824e3feda8a34fd1d6a961a27805c012a1125cad1f76d8bf7b1a92d7719480d90b344e5b4d0260ccf0547
diff --git a/dev-python/path/path-16.6.0.ebuild b/dev-python/path/path-16.6.0.ebuild
new file mode 100644
index 000000000000..ecd7e2ae4fa3
--- /dev/null
+++ b/dev-python/path/path-16.6.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A module wrapper for os.path"
+HOMEPAGE="
+ https://github.com/jaraco/path/
+ https://pypi.org/project/path/
+"
+SRC_URI="
+ https://github.com/jaraco/path/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # unreliable, not really meaningful for end users
+ test_path.py::TestPerformance
+)
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}