summaryrefslogtreecommitdiff
path: root/dev-python/path-py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-24 19:42:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-24 19:42:07 +0100
commitfbd9734cedfe790955100b8e4ab3613457d77b1a (patch)
tree3eda83643563749dd2792dfb880eaeca1d061c18 /dev-python/path-py
parent6abaca02d36f161c81e2d5ee467719a89f88b2c5 (diff)
gentoo resync (3) : 24.07.2021
Diffstat (limited to 'dev-python/path-py')
-rw-r--r--dev-python/path-py/Manifest4
-rw-r--r--dev-python/path-py/path-py-15.1.2.ebuild39
-rw-r--r--dev-python/path-py/path-py-16.0.0.ebuild2
3 files changed, 2 insertions, 43 deletions
diff --git a/dev-python/path-py/Manifest b/dev-python/path-py/Manifest
index 564a49f134ef..3517e0355b0a 100644
--- a/dev-python/path-py/Manifest
+++ b/dev-python/path-py/Manifest
@@ -1,5 +1,3 @@
-DIST path-15.1.2.tar.gz 48280 BLAKE2B 6dd6be743939d4ac1edd5caab18658473d7318eaf255140198db34cfb28c95322ed8ae05284683b18a0146f412ff8a2c14dae60d018740f8bb9cfda861b8ea20 SHA512 76f2a04800154ee8c7b7b9783bf7c63c544da74bb2f92424aeb437448a04dcdec008deab262d3b40d515404e6144bbad44e618d824974654ef10676878415ba4
DIST path-16.0.0.tar.gz 44187 BLAKE2B 839c8a9d10cf4ac3f738a9e661fbfb1059554f965fc8224457c05c249578a18118129b69b46276fe569fc8bc33b398be1462d660bb20b905ecc6ab2b4db3f8fc SHA512 3874321d488543219a081adcb692739fcc4935cddaf563b58fe5a97c2cee4b5b683b2be52d220854b2f2224d15ec2bde054a53862352c249f14f1460a72d5e72
-EBUILD path-py-15.1.2.ebuild 1014 BLAKE2B 6292ac0a45c57935446c4c891f4794968c447c7f7011538497756ca333a4cc3d5a537d1e2e72702c02c8f9944605e2f1f3f48171bc534c382072aba885f177e7 SHA512 a2d31f30156ef22ba08a0fedb1f67248a369eb5a739f6517a3f60330beb613ca177d9919868090b1fb833af2cd55af864e224528869c841019d1d8448088cd2a
-EBUILD path-py-16.0.0.ebuild 999 BLAKE2B ccbe4489b241d7b46765e08caeb661564fed4b504530a426dd14fbdc5fde87b45f92f1ac2746608ad84fd1c155f4345ab941f76ecbfa6dff5beb3027834ddf9d SHA512 0dfc40b0672b7df937cac1b92b1bbdf82014326f6dff72e007eaa9169a180afb6a7b34694eace7eabca212ddf60d1c21802df814fe78230f6d94b67c4e28c847
+EBUILD path-py-16.0.0.ebuild 991 BLAKE2B a34423a4b0ff511cda1b8a151966e776003fb904133da0c9049828213b585ad505a611949e090bee441966b2941904383c1d285d3321c5740389657f1a8296e7 SHA512 0941a3669633d256d38a47f497032229f7590f25d87bf76c7daa43f58d5feb84025ec7fdf26faca12e0cc67b8b5b0bb373f8c773849f6233d56c87f185373497
MISC metadata.xml 382 BLAKE2B f4e983fc27f8e9a578a8469a0b432adf91f622d9993bcdf9a0f25f2786680eb26a67d53d1c97deebc8bbbf7d62ac5b37b2d5a44b39c81f3862e0ffe2cbe2e577 SHA512 61909559eb0ad81e607bdd7b9b147f3e9c71e53721ddd99b1cc2afbe8e33ca7de2b9849ff3ff7468183c5f82f108b958ae0ce3042998972dac8eab6338040151
diff --git a/dev-python/path-py/path-py-15.1.2.ebuild b/dev-python/path-py/path-py-15.1.2.ebuild
deleted file mode 100644
index 1cbdcfd39800..000000000000
--- a/dev-python/path-py/path-py-15.1.2.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
-inherit distutils-r1
-
-MY_P="path-${PV}"
-DESCRIPTION="A module wrapper for os.path"
-HOMEPAGE="https://pypi.org/project/path/ https://github.com/jaraco/path"
-SRC_URI="mirror://pypi/p/path/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-
-RDEPEND="
- dev-python/appdirs[${PYTHON_USEDEP}]
- !<dev-python/pytest-shutil-1.7.0-r1
- !<dev-python/pytest-virtualenv-1.7.0-r1"
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]
- test? (
- dev-python/packaging[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-python_test() {
- local deselect=(
- # unreliable, not really meaningful for end users
- test_path.py::TestPerformance
- )
-
- PYTHONPATH=. pytest -vv ${deselect[@]/#/--deselect } || die
-}
diff --git a/dev-python/path-py/path-py-16.0.0.ebuild b/dev-python/path-py/path-py-16.0.0.ebuild
index 05cfe7a2439c..b0bfdc1c94dc 100644
--- a/dev-python/path-py/path-py-16.0.0.ebuild
+++ b/dev-python/path-py/path-py-16.0.0.ebuild
@@ -14,7 +14,7 @@ S=${WORKDIR}/${MY_P}
SLOT="0"
LICENSE="MIT"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
RDEPEND="
dev-python/appdirs[${PYTHON_USEDEP}]