summaryrefslogtreecommitdiff
path: root/dev-python/path-py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/path-py
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/path-py')
-rw-r--r--dev-python/path-py/Manifest4
-rw-r--r--dev-python/path-py/path-py-16.2.0.ebuild3
-rw-r--r--dev-python/path-py/path-py-16.4.0.ebuild38
3 files changed, 42 insertions, 3 deletions
diff --git a/dev-python/path-py/Manifest b/dev-python/path-py/Manifest
index 7c98048b87f7..57e55d8ad092 100644
--- a/dev-python/path-py/Manifest
+++ b/dev-python/path-py/Manifest
@@ -1,3 +1,5 @@
DIST path-16.2.0.tar.gz 45276 BLAKE2B 40b8eacc7e28398324f24b955adef11e5fc0bd512cd711cd3117f35a322ce0c3959b55255d4c96bbae64f914b5f3768088eb73fb45511c09f2e21bf99b3e9911 SHA512 f893d9fe3539eff0b43e4945076f770ffa7c3125151774d6accaa3a609fce351bc121562deb7ef695c0b1fc7aba12ce7487ae09a0b5daba2d5340586fc41ec79
-EBUILD path-py-16.2.0.ebuild 991 BLAKE2B c796195495866eb4d0a368a7be05bdee25ea3b6d13ab9c94dd116f3a46293dde0ee8b0874d179f1a76bf5e17e76c277a5766ef4a71ad275f5e5cb1a2225b62c6 SHA512 95cf99238062d5e252d4737b2be9cf8d6a883b7a77cbb5493672276c9decec21b26d321aa4ef776d6c0d1457fe3c011c2886218fba4a2007772626354de0dd3b
+DIST path-16.4.0.tar.gz 48289 BLAKE2B 5ae3272ecc92689c18ffc612b8b11923225dcface88fa47dc4f42b0dc960034fa6a3c856a9521ed83c9507616577efc3d1c0a5119b0c5605ea6f6b758cfe6d2b SHA512 bb78119f929fe3b160646b06db8911e737060695ae89c28bcce84835213dfbaa12a34300b540be6b51e9462c5b378b235e1e72536524750ec910255399c513d3
+EBUILD path-py-16.2.0.ebuild 956 BLAKE2B 23a0b85ef969159260e14a5469c3011248188b2769c9e89374e8bc72ddd4122a6dab7776692e8b8a0f76aa0c29b056842a34af7ed7e6ba32843cfc924ad1e3e8 SHA512 835271632f5560cb95c8eba6f8d5d3a535e6a5b4d0940d828842e4dd1cb0dbe033a2a0f778c3638e0e276b87a811f4782bfe080fa8b3024c14e219cbf195efb3
+EBUILD path-py-16.4.0.ebuild 940 BLAKE2B d1c6fadefc5a649f943e2500193ae5becd514030a020139e0ae1c98412f49142a13fc6940b58b3fcd5f6220496b0f1baed94808ad3436571e73a8ca5640230ba SHA512 10cbd0d31ee620d5f14e02c9c71b79e6c62df5227679f193c6148bd05277e21b1e117052ba5cda3a6dfe14405f839afecea7a65bf756d5af9af9cb364ebbd805
MISC metadata.xml 383 BLAKE2B 30f12776bf4f9c1995774d7dc68cd8d9a85b74d514e8239ba76af336e6b08979e496ddaffce999bf0a3557f88ced148335024628b61f765b5bd08bf90b453c5a SHA512 aaceff1caa2714c0b8b3f7373c8721358e63833cfac824e3feda8a34fd1d6a961a27805c012a1125cad1f76d8bf7b1a92d7719480d90b344e5b4d0260ccf0547
diff --git a/dev-python/path-py/path-py-16.2.0.ebuild b/dev-python/path-py/path-py-16.2.0.ebuild
index 706841a1e7b4..161aeaf60c7a 100644
--- a/dev-python/path-py/path-py-16.2.0.ebuild
+++ b/dev-python/path-py/path-py-16.2.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -22,7 +22,6 @@ RDEPEND="
!<dev-python/pytest-virtualenv-1.7.0-r1"
BDEPEND="
dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]
test? (
dev-python/packaging[${PYTHON_USEDEP}]
)"
diff --git a/dev-python/path-py/path-py-16.4.0.ebuild b/dev-python/path-py/path-py-16.4.0.ebuild
new file mode 100644
index 000000000000..559b393dcf0e
--- /dev/null
+++ b/dev-python/path-py/path-py-16.4.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+MY_P="path-${PV}"
+DESCRIPTION="A module wrapper for os.path"
+HOMEPAGE="https://pypi.org/project/path/ https://github.com/jaraco/path"
+SRC_URI="mirror://pypi/p/path/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ !<dev-python/pytest-shutil-1.7.0-r1
+ !<dev-python/pytest-virtualenv-1.7.0-r1
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # unreliable, not really meaningful for end users
+ test_path.py::TestPerformance
+)