summaryrefslogtreecommitdiff
path: root/dev-python/pastescript
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pastescript
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pastescript')
-rw-r--r--dev-python/pastescript/Manifest3
-rw-r--r--dev-python/pastescript/metadata.xml11
-rw-r--r--dev-python/pastescript/pastescript-2.0.2-r1.ebuild59
3 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/pastescript/Manifest b/dev-python/pastescript/Manifest
new file mode 100644
index 000000000000..2250a803709a
--- /dev/null
+++ b/dev-python/pastescript/Manifest
@@ -0,0 +1,3 @@
+DIST PasteScript-2.0.2.tar.gz 117521 BLAKE2B 2de72050ee7f5b7037b99f9661b5445e523607afc84a8846f0e5d9e89196e302627f552825ce0e4f821b7ed9ed2713c87d7b504a4e2abf092f1e8fa014c40c4b SHA512 2f093eb982972fed354219c75c2e008931cea553960cea8aaafbe57cde8556de5626e7eb9bb3b9b7328bad3b7d9899f11fc9773a65380396dae506e7531516de
+EBUILD pastescript-2.0.2-r1.ebuild 1287 BLAKE2B ab9208cdd47205d96915fed68e5e84e0feb2a2f4eddcdfbbeb2aa061d58121a478b5297d3d65b7cdcd00c530767adda4a12332622c0214ac3736366a3dfd274c SHA512 b56de19e2df01856797d87b1098609f1e8b34f4c57901469dd5a90ff1d66bee9295f663473ced5a4f0e6519c75fd8a304398a9c045454ac6ba85b4507a498705
+MISC metadata.xml 324 BLAKE2B ef67daa0f9e2595c0b35ed1b919c98129443d224c81a7ea6bd0ef919845339dd9cd45ea96ff4a4aa0176b24c61a57bc2cf8ee2f0c2d10386dbae1c904d5426ab SHA512 48a93ec635e32513438b44cb67bd7302c6bc55c72281d253ee4cd4b0a7d4c25ec61b028d861fa1acd2b40f22479fc0a1f726d3334c8a2970ad2b45729279ec47
diff --git a/dev-python/pastescript/metadata.xml b/dev-python/pastescript/metadata.xml
new file mode 100644
index 000000000000..f51d9da0abb6
--- /dev/null
+++ b/dev-python/pastescript/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">PasteScript</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pastescript/pastescript-2.0.2-r1.ebuild b/dev-python/pastescript/pastescript-2.0.2-r1.ebuild
new file mode 100644
index 000000000000..de7027b53bae
--- /dev/null
+++ b/dev-python/pastescript/pastescript-2.0.2-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+MY_PN="PasteScript"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A pluggable command-line frontend, including commands to setup package file layouts"
+HOMEPAGE="https://pypi.org/project/PasteScript/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/namespace-paste[${PYTHON_USEDEP}]
+ >=dev-python/paste-1.3[${PYTHON_USEDEP}]
+ dev-python/pastedeploy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? (
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+# Tests are broken.
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ if use doc; then
+ einfo "Generation of documentation"
+ esetup.py build_sphinx
+ fi
+}
+
+python_test() {
+ nosetests -v -v || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use doc; then
+ cd "${BUILD_DIR}"/sphinx/html || die
+ dohtml -r [a-z]* _static
+ fi
+
+ find "${D}" -name '*.pth' -delete || die
+}