summaryrefslogtreecommitdiff
path: root/dev-python/pastedeploy/pastedeploy-2.1.1-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/pastedeploy/pastedeploy-2.1.1-r3.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/pastedeploy/pastedeploy-2.1.1-r3.ebuild')
-rw-r--r--dev-python/pastedeploy/pastedeploy-2.1.1-r3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pastedeploy/pastedeploy-2.1.1-r3.ebuild b/dev-python/pastedeploy/pastedeploy-2.1.1-r3.ebuild
new file mode 100644
index 000000000000..f783815afabb
--- /dev/null
+++ b/dev-python/pastedeploy/pastedeploy-2.1.1-r3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+MY_PN="PasteDeploy"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Load, configure, and compose WSGI applications and servers"
+HOMEPAGE="https://pypi.org/project/PasteDeploy/"
+# pypi tarball does not include tests
+SRC_URI="https://github.com/Pylons/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
+
+RDEPEND="
+ !dev-python/namespace-paste
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-change-sphinx-theme.patch"
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}