summaryrefslogtreecommitdiff
path: root/dev-python/pastedeploy/pastedeploy-1.5.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pastedeploy/pastedeploy-1.5.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pastedeploy/pastedeploy-1.5.2.ebuild')
-rw-r--r--dev-python/pastedeploy/pastedeploy-1.5.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pastedeploy/pastedeploy-1.5.2.ebuild b/dev-python/pastedeploy/pastedeploy-1.5.2.ebuild
new file mode 100644
index 000000000000..77a24a3f5276
--- /dev/null
+++ b/dev-python/pastedeploy/pastedeploy-1.5.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+MY_PN="PasteDeploy"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Load, configure, and compose WSGI applications and servers"
+HOMEPAGE="http://pythonpaste.org/deploy/ https://pypi.python.org/pypi/PasteDeploy"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="doc"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ use doc && dodoc docs/*.txt
+}