summaryrefslogtreecommitdiff
path: root/dev-python/pastedeploy/pastedeploy-1.5.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pastedeploy/pastedeploy-1.5.2-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pastedeploy/pastedeploy-1.5.2-r1.ebuild')
-rw-r--r--dev-python/pastedeploy/pastedeploy-1.5.2-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pastedeploy/pastedeploy-1.5.2-r1.ebuild b/dev-python/pastedeploy/pastedeploy-1.5.2-r1.ebuild
new file mode 100644
index 000000000000..f23af57e0f7c
--- /dev/null
+++ b/dev-python/pastedeploy/pastedeploy-1.5.2-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1 vcs-snapshot
+
+MY_PN="PasteDeploy"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Load, configure, and compose WSGI applications and servers"
+HOMEPAGE="https://pypi.org/project/PasteDeploy/"
+# pypi tarball does not include tests
+SRC_URI="https://bitbucket.org/ianb/pastedeploy/get/${PV}.tar.gz -> ${P}-r1.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="doc test"
+
+RDEPEND="dev-python/namespace-paste[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${P}-r1
+
+PATCHES=(
+ "${FILESDIR}"/${P}-py3-tests.patch
+)
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ use doc && dodoc docs/*.txt
+ find "${D}" -name '*.pth' -delete || die
+}