summaryrefslogtreecommitdiff
path: root/dev-python/pastedeploy/pastedeploy-1.5.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pastedeploy/pastedeploy-1.5.2-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pastedeploy/pastedeploy-1.5.2-r1.ebuild')
-rw-r--r--dev-python/pastedeploy/pastedeploy-1.5.2-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pastedeploy/pastedeploy-1.5.2-r1.ebuild b/dev-python/pastedeploy/pastedeploy-1.5.2-r1.ebuild
new file mode 100644
index 000000000000..094cbe4b67ee
--- /dev/null
+++ b/dev-python/pastedeploy/pastedeploy-1.5.2-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1 vcs-snapshot
+
+MY_PN="PasteDeploy"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Load, configure, and compose WSGI applications and servers"
+HOMEPAGE="http://pythonpaste.org/deploy/ https://pypi.python.org/pypi/PasteDeploy"
+# pypi tarball does not include tests
+SRC_URI="https://bitbucket.org/ianb/pastedeploy/get/${PV}.tar.gz -> ${P}-r1.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="doc test"
+
+RDEPEND="dev-python/namespace-paste[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${P}-r1
+
+PATCHES=(
+ "${FILESDIR}"/${P}-py3-tests.patch
+)
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ use doc && dodoc docs/*.txt
+ find "${D}" -name '*.pth' -delete || die
+}