summaryrefslogtreecommitdiff
path: root/dev-python/pastedeploy/pastedeploy-1.5.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-python/pastedeploy/pastedeploy-1.5.2-r1.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-python/pastedeploy/pastedeploy-1.5.2-r1.ebuild')
-rw-r--r--dev-python/pastedeploy/pastedeploy-1.5.2-r1.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/pastedeploy/pastedeploy-1.5.2-r1.ebuild b/dev-python/pastedeploy/pastedeploy-1.5.2-r1.ebuild
deleted file mode 100644
index 84034e878269..000000000000
--- a/dev-python/pastedeploy/pastedeploy-1.5.2-r1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-
-inherit distutils-r1 vcs-snapshot
-
-MY_PN="PasteDeploy"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Load, configure, and compose WSGI applications and servers"
-HOMEPAGE="https://pypi.org/project/PasteDeploy/"
-# pypi tarball does not include tests
-SRC_URI="https://bitbucket.org/ianb/pastedeploy/get/${PV}.tar.gz -> ${P}-r1.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/namespace-paste[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-S=${WORKDIR}/${P}-r1
-
-PATCHES=(
- "${FILESDIR}"/${P}-py3-tests.patch
-)
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- use doc && dodoc docs/*.txt
- find "${D}" -name '*.pth' -delete || die
-}