summaryrefslogtreecommitdiff
path: root/dev-python/parver/parver-0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-04 11:51:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-04 11:51:15 +0100
commit713e25c0c3d1e5434ac60ec0549708ec2f744bb4 (patch)
tree9e9281ff07875c667fb3bf223166de68137f4635 /dev-python/parver/parver-0.5.ebuild
parent08b4047e14c989cfb931eff95973837f54ccc9e1 (diff)
gentoo auto-resync : 04:10:2023 - 11:51:15
Diffstat (limited to 'dev-python/parver/parver-0.5.ebuild')
-rw-r--r--dev-python/parver/parver-0.5.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/parver/parver-0.5.ebuild b/dev-python/parver/parver-0.5.ebuild
new file mode 100644
index 000000000000..d24530aff026
--- /dev/null
+++ b/dev-python/parver/parver-0.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Parse and manipulate version numbers"
+HOMEPAGE="
+ https://github.com/RazerM/parver/
+ https://pypi.org/project/parver/
+"
+SRC_URI="
+ https://github.com/RazerM/parver/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/Arpeggio-1.7[${PYTHON_USEDEP}]
+ >=dev-python/attrs-19.2[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest