summaryrefslogtreecommitdiff
path: root/dev-python/parso
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
commitf78108598211053d41752a83e0345441bb9014ae (patch)
treedd2fc7ae0a1aea7bda4942ab0c453d1e55284b37 /dev-python/parso
parentdc45b83b28fb83e9659492066e347b8dc60bc9e3 (diff)
gentoo resync : 11.02.2018
Diffstat (limited to 'dev-python/parso')
-rw-r--r--dev-python/parso/Manifest3
-rw-r--r--dev-python/parso/metadata.xml12
-rw-r--r--dev-python/parso/parso-0.1.1.ebuild35
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/parso/Manifest b/dev-python/parso/Manifest
new file mode 100644
index 000000000000..c40fc79dcd62
--- /dev/null
+++ b/dev-python/parso/Manifest
@@ -0,0 +1,3 @@
+DIST parso-0.1.1.tar.gz 376876 BLAKE2B ad0b9492273d23da1f4133a2f1e6edd2fa7f2213dbe12868f891863e9286fa0281de7fc6c6924b78a5820f94867971bbc09f18b3d0f2e4832c9c875850205254 SHA512 1199651136af1c9f0801a031a197e367f7fa73b5878b863103a506481e8b325e6b305e4260510a567dccf91f298fd7e9e5674f4dc410765ae1f9112f742aa6a0
+EBUILD parso-0.1.1.ebuild 871 BLAKE2B b55ed106e5bc74b0fe06b8c3e642abba305d5fa39e34aa50f6ae9564dbd68c7ac2ecfa0364f41739c94e06571c1ed8778fe6be937e9c92f784388e3c46bd740a SHA512 ac4aa43c7bd671aa48c74f139078f1ab9d5f8de49f0b1bc8424aa8b22547195f573f2b39bf03a993f44eeef2aedf86b66e4bb6db57e228515e4efb3735565fbb
+MISC metadata.xml 377 BLAKE2B 0ac7d9c46c0b591fe46ff373bcb8942261cf0b819d9397500928546c4b07541c958edb116ecf1ff79f0a83c2f02784b019e7d64bd8a82bdfb397ef70fbbaa0c3 SHA512 7d719c633f81372caafbfb0a913fa455fd1d150210ea09713a0888b38d18ccae646b17bbe32a66b931016ee6e4bc826a1670a033466c945a2591e77f9d6d7b7c
diff --git a/dev-python/parso/metadata.xml b/dev-python/parso/metadata.xml
new file mode 100644
index 000000000000..0d25fbf1ae0e
--- /dev/null
+++ b/dev-python/parso/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">parso</remote-id>
+ <remote-id type="github">davidhalter/parso</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/parso/parso-0.1.1.ebuild b/dev-python/parso/parso-0.1.1.ebuild
new file mode 100644
index 000000000000..99e6a66edd99
--- /dev/null
+++ b/dev-python/parso/parso-0.1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="a python parser that supports error recovery and round-trip parsing"
+HOMEPAGE="https://github.com/davidhalter/parso https://pypi.python.org/pypi/parso"
+SRC_URI="https://github.com/davidhalter/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test -v test || die "tests failed with ${EPYTHON}"
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( "${S}"/docs/_build/html/. )
+ distutils-r1_python_install_all
+}