summaryrefslogtreecommitdiff
path: root/dev-python/parso
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /dev-python/parso
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'dev-python/parso')
-rw-r--r--dev-python/parso/Manifest1
-rw-r--r--dev-python/parso/parso-0.8.3-r1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/parso/Manifest b/dev-python/parso/Manifest
index 1275f3e1908c..f4d1bcc845f0 100644
--- a/dev-python/parso/Manifest
+++ b/dev-python/parso/Manifest
@@ -3,5 +3,6 @@ AUX parso-0.8.2-flaky-test.patch 947 BLAKE2B b6ece3214328f3121e4de8217395ac10867
DIST parso-0.7.1.tar.gz 399842 BLAKE2B 1e47c1dd6846d01aa5820d7cedc3eafcf12ea0d4a2e95fa3f54429633b1c12dc39a4abe237fa46eb629408006777bd1f512cf878025b55119568ac19729b8c19 SHA512 318969a7a941c4a0948e58643b07b6f5c446ea166b3a8e44a556f0677ec9a36d7dc8c6d37ca7bce3f8276ee3d7144e22fbaaeac90c738fb90f7e94a0cf8abf7d
DIST parso-0.8.3.tar.gz 397648 BLAKE2B 8942408e27198075c92ef51f7a191cc7781eb3a5110119b91fd95f86e13ebe2fbfee11022a2bfec794150f60b3af8c4d5f324cb011703cd581c17f92232ae5bf SHA512 7874460053662d40c2cfcf0015e330e1c8201eeb07682e2079a636db553a82dc25b70b14ad0f0c82fb817f655359d695101a17f616abf9a39f49c61ae5fd49b1
EBUILD parso-0.7.1-r1.ebuild 968 BLAKE2B 2477e3999525e9de62274bb1792cf441f2a7a338681e4fd999663347d54737946c6443a2f5978dbe45fec129b11e5438b294d29d7bacfe341e4cb214d9227337 SHA512 b106824ea5aaca2347acaf3ef22a0aedc64b1f914d0009b986951f8a29463d1230bd284f431de9b4bfa38a4d395bbd9960f3ac0fd0b0b45513942c98139dc672
+EBUILD parso-0.8.3-r1.ebuild 752 BLAKE2B 3de68b48da19a18168ec6ccb5641fb2be704b56ad7a7987d9a23971471d0cca166e83b55471c317044c345ca34ae723cf99d78aac53cd7fd42854a36ef189dd3 SHA512 f2f874a6360e419891a18abc081ed832c15f3831a5323fc636076e8f46f57862a973d18749e3bad94e21f68ed655001cf01c150a6522607540fd65fe7097e0c2
EBUILD parso-0.8.3.ebuild 702 BLAKE2B ff951fe8ebe1d369872198111261cebfd1fd14c770528b72b0c62a4d448efaae418369ea1b4df4f80a695f1a3f9ad834d9ad2d8f9148cb09f2a54bd5e7d8bdec SHA512 62e54c6d14c5e7ab2561ead4d477eee0c0d168b46dacefe115f43bab8f101c9e6a8f4e8120b5ff95bb1405195f6ac916e5cea6ad9b61992ad5f7611afe31a289
MISC metadata.xml 403 BLAKE2B be2e4f9dd7e074a3b76a591f034f679bff13b7dc36d8b206e45550276533ba752a8e04162ddf4f580a8e247d57f48a997cac34c14dc7b5ae4a3d74751fb9cac4 SHA512 10517311994816074cfcc4809206ccbdb6a9ac3430e92cf9c4dfc45d8e95a92843843e2bf1a19b97aaa3c330bb923581e4ea6cf6a88f1063f2dab8d041f6c90f
diff --git a/dev-python/parso/parso-0.8.3-r1.ebuild b/dev-python/parso/parso-0.8.3-r1.ebuild
new file mode 100644
index 000000000000..e2527b1ee829
--- /dev/null
+++ b/dev-python/parso/parso-0.8.3-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A python parser that supports error recovery and round-trip parsing"
+HOMEPAGE="
+ https://github.com/davidhalter/parso/
+ https://pypi.org/project/parso/
+"
+SRC_URI="
+ https://github.com/davidhalter/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # py3.10 changed exception messages
+ test/test_python_errors.py::test_python_exception_matches
+)