summaryrefslogtreecommitdiff
path: root/dev-python/parso/parso-0.8.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/parso/parso-0.8.3-r1.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/parso/parso-0.8.3-r1.ebuild')
-rw-r--r--dev-python/parso/parso-0.8.3-r1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-python/parso/parso-0.8.3-r1.ebuild b/dev-python/parso/parso-0.8.3-r1.ebuild
index 7aae84fd1c6c..8db1f3257f01 100644
--- a/dev-python/parso/parso-0.8.3-r1.ebuild
+++ b/dev-python/parso/parso-0.8.3-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
inherit distutils-r1
@@ -28,4 +28,7 @@ distutils_enable_tests pytest
EPYTEST_DESELECT=(
# py3.10 changed exception messages
test/test_python_errors.py::test_python_exception_matches
+ # With python3.11 this additional file is run by pytest,
+ # but it is not actually a test and thus fails
+ parso/python/token.py::parso.python.token.PythonTokenTypes
)