summaryrefslogtreecommitdiff
path: root/dev-python/parse/parse-1.20.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-12 00:08:13 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-12 00:08:13 +0100
commitf0ddcad13515f66d2f3bf827d33c277bdba7e1dd (patch)
tree3e1da8fa4626163bda62e9e8b6129867de5be46d /dev-python/parse/parse-1.20.2.ebuild
parent65ff3cc3bd9c3f8e718a67dfecf1f8215bf5d1d4 (diff)
gentoo auto-resync : 12:06:2024 - 00:08:13
Diffstat (limited to 'dev-python/parse/parse-1.20.2.ebuild')
-rw-r--r--dev-python/parse/parse-1.20.2.ebuild17
1 files changed, 17 insertions, 0 deletions
diff --git a/dev-python/parse/parse-1.20.2.ebuild b/dev-python/parse/parse-1.20.2.ebuild
new file mode 100644
index 000000000000..664ce6fee31c
--- /dev/null
+++ b/dev-python/parse/parse-1.20.2.ebuild
@@ -0,0 +1,17 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="Parse strings using a specification based on the Python format() syntax"
+HOMEPAGE="https://github.com/r1chardj0n3s/parse/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+distutils_enable_tests pytest