summaryrefslogtreecommitdiff
path: root/dev-python/parse/parse-1.19.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-20 01:14:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-20 01:14:49 +0100
commitbc4457d8e0e53a2e43c4254d08053ba9708663e1 (patch)
tree4f8809f23d683eed73ef800d99ce7aa628a82527 /dev-python/parse/parse-1.19.1.ebuild
parent5f593f75391c28294f0dffa4dd1df280a4d8df73 (diff)
gentoo auto-resync : 20:06:2023 - 01:14:49
Diffstat (limited to 'dev-python/parse/parse-1.19.1.ebuild')
-rw-r--r--dev-python/parse/parse-1.19.1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/parse/parse-1.19.1.ebuild b/dev-python/parse/parse-1.19.1.ebuild
new file mode 100644
index 000000000000..c66e76fac653
--- /dev/null
+++ b/dev-python/parse/parse-1.19.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1
+
+DESCRIPTION="Parse strings using a specification based on the Python format() syntax"
+HOMEPAGE="https://pypi.org/project/parse/"
+SRC_URI="https://github.com/r1chardj0n3s/parse/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+# unkeyworded for now, may break revdeps and needs more looking into
+#KEYWORDS="~amd64 ~arm64 ~x86"
+
+distutils_enable_tests unittest