summaryrefslogtreecommitdiff
path: root/dev-python/paramiko
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-19 07:53:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-19 07:53:50 +0000
commit32b8124b0a5827960601f2183a970103b3d231b7 (patch)
treefebd1cb81d2417f5452d0e21f81d06663f12caa3 /dev-python/paramiko
parent89e7f1cd6dd17f245898939477ef38d45dd112b9 (diff)
gentoo auto-resync : 19:12:2023 - 07:53:49
Diffstat (limited to 'dev-python/paramiko')
-rw-r--r--dev-python/paramiko/Manifest2
-rw-r--r--dev-python/paramiko/paramiko-3.4.0.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/paramiko/Manifest b/dev-python/paramiko/Manifest
index 3a0a241a46e2..65a8d3cbb279 100644
--- a/dev-python/paramiko/Manifest
+++ b/dev-python/paramiko/Manifest
@@ -1,5 +1,7 @@
AUX paramiko-3.2.0-disable-server.patch 1771 BLAKE2B 3cab494873956d6f36b8ea85903141a49eb515fd92851f041f91418dc58acc77cdaf00a215c8e681d037d78eabfc7718a5670f2ca6af02fe357daece9a48819e SHA512 9f2f85518dec8668d096fa1db77ec5219f14fb6127c29bbdc2ba47f55e3526e9f1dbca421adb18033a8358c0efac7db723536b26bd8f45c8583503fb4ae58d76
AUX paramiko-3.2.0-nih-test-deps.patch 4289 BLAKE2B 4a77852f0ae3cda52eca8844f4bf2571c17a0935088973f48c46abf250081845a870fb52d8ebafb108f634dbe86fbe784eefd49d9240c50f911d56173d1e3d71 SHA512 4e0bed394e4c8be19108cc0a7253d6306a698a3cc09b40c18459c8e16591ff42c41cb4f385fc05dcf902161fa23ce2b7d00c665784b9106344a5ca42e4f2a788
DIST paramiko-3.3.1.gh.tar.gz 370001 BLAKE2B df3c82fdaeccf4aa4d10922dbdfdf8b8cd77975e7c8980b33ddb082a68dd50fd61dd3e0494f45f81c92ce3827f301bfffa4fd09e132e312de9fd490536b066bd SHA512 94ee41ceb99b0c02e455aa6a7d0fea5f88edc6e9e80dfd4d07417875bcbcc15bbef842106c7a38bae93c0e1008d99d01d7b7a026b005358ae1846a2f931f775c
+DIST paramiko-3.4.0.gh.tar.gz 374441 BLAKE2B a6ea03d40e477cb02c1293c46025909251f8eec2be70638bf850638d9fe8c15bfe0e278697e41f3595f482b8f0755d911b905b11db2324eca597fc9be2a22f24 SHA512 f78fccf653d05acee78dfb76fb662c85fbfea7901fd94460a2d2e526c9b25169993051d20c16cfe0b7745008b1ea3a745fc9a280386d98a06689aaadf78f6752
EBUILD paramiko-3.3.1.ebuild 1345 BLAKE2B 27c0531cd9cd5d79ee5f34af106e7e626251706344466f3afbfbe869e543b188e5c4469c4cc7e245faf1fdd693d1ddba2e303aeea2b73de044360a15db7ff622 SHA512 62d973550168ae3e4a675f546b40c657381cd61826c3d417e333ca9b34474c1b6e1402c4754e992ecc2e8df66772dfeeb8720c821f10ecc0eaa9a20a4a0125d5
+EBUILD paramiko-3.4.0.ebuild 1352 BLAKE2B d6f186feef7e1fbfe7fe82fb63a7c72a67d41ede49be1724243418387f3638610973efb9fb2554db6817495cede80e589debcf66cee7fa7ca490560f839e663e SHA512 abc9dd7bd2f8807b10776ad55a75f6bffe771f35e4a73c5fd8177ccb1b162284db952209f365a57b9ab8f16a08230dcb4e2ce05a3f96ceb71d4500bf3db8413b
MISC metadata.xml 1222 BLAKE2B 46fb6385f6779cbc13fa54090dd5dfa0b5a7b5a753f728b133fa79a1e1c779a5652d6b38c5ea11cfcb505178b2ba70d9000dabba6228e38f30f426ecb1c49a3f SHA512 bf07a537ed375a3bf58d219c18ccfc29c810554041943e62819a46b63ce3fbcdd2197085dbeeb7ad36e0e601700edec6121ce5cc83dce1c7435d663473df2583
diff --git a/dev-python/paramiko/paramiko-3.4.0.ebuild b/dev-python/paramiko/paramiko-3.4.0.ebuild
new file mode 100644
index 000000000000..57c242767f78
--- /dev/null
+++ b/dev-python/paramiko/paramiko-3.4.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="SSH2 protocol library"
+HOMEPAGE="
+ https://www.paramiko.org/
+ https://github.com/paramiko/paramiko/
+ https://pypi.org/project/paramiko/
+"
+SRC_URI="
+ https://github.com/paramiko/paramiko/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="examples server"
+
+RDEPEND="
+ >=dev-python/bcrypt-3.1.3[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.5[${PYTHON_USEDEP}]
+ >=dev-python/pynacl-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # upstream doesn't really maintain the gssapi support
+ tests/test_gssapi.py
+ tests/test_kex_gss.py
+ tests/test_ssh_gss.py
+)
+
+src_prepare() {
+ local PATCHES=(
+ "${FILESDIR}/${PN}-3.2.0-nih-test-deps.patch"
+ )
+
+ if ! use server; then
+ PATCHES+=( "${FILESDIR}/${PN}-3.2.0-disable-server.patch" )
+ fi
+ distutils-r1_src_prepare
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ docinto examples
+ dodoc -r demos/*
+ fi
+}