summaryrefslogtreecommitdiff
path: root/dev-python/paho-mqtt/paho-mqtt-1.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-16 16:18:18 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-16 16:18:18 +0000
commit0704956f7256f1f618cc5e03af2c1dbd0e83dbc5 (patch)
tree881671532c0c3c82ebd4523b6d6cbc8ace982aae /dev-python/paho-mqtt/paho-mqtt-1.5.0.ebuild
parent21435953e16cda318a82334ddbadb3b5c36d9ea7 (diff)
gentoo resync : 16.01.2020
Diffstat (limited to 'dev-python/paho-mqtt/paho-mqtt-1.5.0.ebuild')
-rw-r--r--dev-python/paho-mqtt/paho-mqtt-1.5.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/paho-mqtt/paho-mqtt-1.5.0.ebuild b/dev-python/paho-mqtt/paho-mqtt-1.5.0.ebuild
new file mode 100644
index 000000000000..b60266361e63
--- /dev/null
+++ b/dev-python/paho-mqtt/paho-mqtt-1.5.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client class with support for both MQTT v3.1 and v3.1.1"
+HOMEPAGE="https://www.eclipse.org/paho/clients/python/"
+SRC_URI="https://github.com/eclipse/paho.mqtt.python/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ ) "
+
+S="${WORKDIR}/paho.mqtt.python-${PV}"
+
+src_prepare() {
+ eapply "${FILESDIR}/${P}-strip-test-dependency.patch"
+ default
+}
+
+python_test() {
+ esetup.py test
+}