summaryrefslogtreecommitdiff
path: root/dev-python/pafy/pafy-0.5.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /dev-python/pafy/pafy-0.5.5.ebuild
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'dev-python/pafy/pafy-0.5.5.ebuild')
-rw-r--r--dev-python/pafy/pafy-0.5.5.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/pafy/pafy-0.5.5.ebuild b/dev-python/pafy/pafy-0.5.5.ebuild
new file mode 100644
index 000000000000..f9627f434ce8
--- /dev/null
+++ b/dev-python/pafy/pafy-0.5.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/mps-youtube/pafy.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Python library to retrieve YouTube content and metadata"
+HOMEPAGE="https://pythonhosted.org/pafy/ https://pypi.org/project/pafy/"
+
+LICENSE="LGPL-3"
+SLOT="0"
+
+RDEPEND="net-misc/youtube-dl[${PYTHON_USEDEP}]"