summaryrefslogtreecommitdiff
path: root/dev-python/packaging
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/packaging
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/packaging')
-rw-r--r--dev-python/packaging/Manifest6
-rw-r--r--dev-python/packaging/files/packaging-16.8-distutils.patch14
-rw-r--r--dev-python/packaging/metadata.xml12
-rw-r--r--dev-python/packaging/packaging-16.8.ebuild51
-rw-r--r--dev-python/packaging/packaging-17.1.ebuild51
5 files changed, 134 insertions, 0 deletions
diff --git a/dev-python/packaging/Manifest b/dev-python/packaging/Manifest
new file mode 100644
index 000000000000..c7fb3d5ac542
--- /dev/null
+++ b/dev-python/packaging/Manifest
@@ -0,0 +1,6 @@
+AUX packaging-16.8-distutils.patch 447 BLAKE2B ee667f6aed01fc273092b896acafc676e399a2bf8e68324e1f08d20738863e272a8ab13bac2e40d1216f44296711281a177c1382337d27d439873230aa323ea8 SHA512 080a1af701c81f694beb336e6239661d04932db904cc6c0ea7e9fd2c2d0e9a42ac3690dfd64eee745c12368f222d20d4b2cdd9d578d7a3b7142924f41b1887d3
+DIST packaging-16.8.tar.gz 44706 BLAKE2B 6443f05d3745eb6c4cc3d51fccfb1afcfa207ac12498be4d15cd0f5c52c80435f8ea513589e8aec671cf88b10cc8c98555e7cac7fe9a1e0c67f4625fce83f80f SHA512 d1a7b65472c7c02dd758f0c469d6c6aeea34de7b798613f7fcdf45fcccbeba1e9085cab113fa89b392a60f758f8747d13b1c265c809566990c22e61ca8db49bb
+DIST packaging-17.1.tar.gz 49849 BLAKE2B ceea74025c55c832cdd36b8464bb15862d8ee60387de973d7453d5cb8ec0b430d1e49a1b13c9dccb8b9c4c898cb07829f6fd04ca700d8cb2c5ba2b7abc0d160e SHA512 52d2f482ae5cd0f8e7b3ac35c4b270ca736bc4f7ebaa569631d1dcb8ea024ee6f75127ca2aa3c95e686ebbd427de2ef4bc01bcd839591f7b4c1e26f9b8d9acb0
+EBUILD packaging-16.8.ebuild 1446 BLAKE2B dcc951ac9f4946e32193b32b6b9f109015012cb58fcf168189a60798981ea9426aba1d2f0e4865e260113e40494b49d17c39ed58b42c488473d27312ee952576 SHA512 3782fa57184fb01bd4ff84f6714c09cee68027342ec545e77391eca79c60628e781e12664fc61a92ba405176daa5c0b963fead74f9d2a76542f9e71f38f371de
+EBUILD packaging-17.1.ebuild 1459 BLAKE2B 22037b5a09efb95b1f74e7eb2bd41577832b2bc034f7343fd0f3c76ac2f47d79f2e6be339264c3f131e884b0513cc9cda5c8b7cb6d70e29cfe6843556688f132 SHA512 f6b1d5a0ed53d4677982954e8ebacfeaa95076d4aaa8e3dc8fa12d843a417adb4ca428637e49e2969edd74e926c88a35831fcc924b750b3030ab4ac575280187
+MISC metadata.xml 366 BLAKE2B 62088f9e06b99999bcb0082f1ff6d6e243c8502a7e3f399699cded85fa65395f558e019b08342c73e4f078183cd0732d88058fab8fba984ba0b531c19ff6560c SHA512 f326b75f4603bc9e4455665dd526e381eb1973c8edc319e1d69b824f93ee885931fa29e74f9da8582f5af78a1ddba2fcc2d983fb98cbdc4cfd87b82c7a0f3ba4
diff --git a/dev-python/packaging/files/packaging-16.8-distutils.patch b/dev-python/packaging/files/packaging-16.8-distutils.patch
new file mode 100644
index 000000000000..84bbb618a6fe
--- /dev/null
+++ b/dev-python/packaging/files/packaging-16.8-distutils.patch
@@ -0,0 +1,14 @@
+--- a/setup.py
++++ b/setup.py
+@@ -13,10 +13,7 @@ import re
+ # dependency when projects attempt to unbundle stuff from setuptools and pip.
+ # Though we don't really support that, it makes things easier if we do this and
+ # should hopefully cause less issues for end users.
+-try:
+- from setuptools import setup
+-except ImportError:
+- from distutils.core import setup
++from distutils.core import setup
+
+
+ base_dir = os.path.dirname(__file__)
diff --git a/dev-python/packaging/metadata.xml b/dev-python/packaging/metadata.xml
new file mode 100644
index 000000000000..b995a0f3bbcc
--- /dev/null
+++ b/dev-python/packaging/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">packaging</remote-id>
+ <remote-id type="github">pypa/packaging</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/packaging/packaging-16.8.ebuild b/dev-python/packaging/packaging-16.8.ebuild
new file mode 100644
index 000000000000..08fac28d7652
--- /dev/null
+++ b/dev-python/packaging/packaging-16.8.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Core utilities for Python packages"
+HOMEPAGE="https://github.com/pypa/packaging https://pypi.org/project/packaging/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="|| ( Apache-2.0 BSD-2 )"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/pyparsing-2.1.10[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-16.8-distutils.patch"
+)
+
+python_test() {
+ py.test --capture=no --strict -v || die
+}
+
+pkg_preinst() {
+ # https://bugs.gentoo.org/585146
+ cd "${HOME}" || die
+
+ _cleanup() {
+ local pyver=$("${PYTHON}" -c "from distutils.sysconfig import get_python_version; print(get_python_version())")
+ local egginfo="${ROOT%/}$(python_get_sitedir)/${P}-py${pyver}.egg-info"
+ if [[ -d ${egginfo} ]]; then
+ echo rm -r "${egginfo}"
+ rm -r "${egginfo}" || die "Failed to remove egg-info directory"
+ fi
+ }
+ python_foreach_impl _cleanup
+}
diff --git a/dev-python/packaging/packaging-17.1.ebuild b/dev-python/packaging/packaging-17.1.ebuild
new file mode 100644
index 000000000000..7f08aa333c6b
--- /dev/null
+++ b/dev-python/packaging/packaging-17.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Core utilities for Python packages"
+HOMEPAGE="https://github.com/pypa/packaging https://pypi.org/project/packaging/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="|| ( Apache-2.0 BSD-2 )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/pyparsing-2.1.10[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-16.8-distutils.patch"
+)
+
+python_test() {
+ py.test --capture=no --strict -v || die
+}
+
+pkg_preinst() {
+ # https://bugs.gentoo.org/585146
+ cd "${HOME}" || die
+
+ _cleanup() {
+ local pyver=$("${PYTHON}" -c "from distutils.sysconfig import get_python_version; print(get_python_version())")
+ local egginfo="${ROOT%/}$(python_get_sitedir)/${P}-py${pyver}.egg-info"
+ if [[ -d ${egginfo} ]]; then
+ echo rm -r "${egginfo}"
+ rm -r "${egginfo}" || die "Failed to remove egg-info directory"
+ fi
+ }
+ python_foreach_impl _cleanup
+}