summaryrefslogtreecommitdiff
path: root/dev-python/packaging
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-28 20:40:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-28 20:40:51 +0000
commit9c417bacd51da6d8b57fa9f37425161d30d4b95b (patch)
tree47c9d6e4243f39a1f48afd54c969b65b00a5c649 /dev-python/packaging
parentd934827bf44b7cfcf6711964418148fa60877668 (diff)
gentoo resync : 28.11.2020
Diffstat (limited to 'dev-python/packaging')
-rw-r--r--dev-python/packaging/Manifest4
-rw-r--r--dev-python/packaging/packaging-20.5.ebuild37
-rw-r--r--dev-python/packaging/packaging-20.7.ebuild37
3 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/packaging/Manifest b/dev-python/packaging/Manifest
index ab7d6bf97cb0..cab7662fdfe3 100644
--- a/dev-python/packaging/Manifest
+++ b/dev-python/packaging/Manifest
@@ -1,4 +1,8 @@
AUX packaging-16.8-distutils.patch 447 BLAKE2B ee667f6aed01fc273092b896acafc676e399a2bf8e68324e1f08d20738863e272a8ab13bac2e40d1216f44296711281a177c1382337d27d439873230aa323ea8 SHA512 080a1af701c81f694beb336e6239661d04932db904cc6c0ea7e9fd2c2d0e9a42ac3690dfd64eee745c12368f222d20d4b2cdd9d578d7a3b7142924f41b1887d3
DIST packaging-20.4.tar.gz 74402 BLAKE2B 3c667c1605445aec37d264ec3846a1a6678f13a12aecc09a6d16e09ea27041fcd65d23538acef4f6272ab0458ce479c42906b15cb6eddd9c8001b1970c23e4fc SHA512 d53912041a9950efb5d221fc968adc328c2ef1e54ec9806d2158fd6db1b170e37afb05213f5750b10c59927504083ca3781c958caa0c802b1c7c0fe1ac1682a4
+DIST packaging-20.5.gh.tar.gz 75111 BLAKE2B b088b85fc042b48337878c0f663934f32f90eb792ba53257b1b0879a097ef042b67a9cff56b23f5e0187a3df0f89092e0210939382851f0ae917f6ef00ad73ff SHA512 ef3c4853c30d9635b9372d6861cc0df8f7fc5a1d784e5f3effe3f315da0f24662ac939e70f55c6e9bb8864da95b9f75bc0df093f12c0f5c2af654b5354a5f081
+DIST packaging-20.7.gh.tar.gz 75182 BLAKE2B f3ba27ec33db576273609f28aabb5edab4acd07d8174c96e3a1608eacdc1a571d2ce96cc4e38c50c964ae5a716bbca077effd6dea039b25ac7bd6ce5707ae08b SHA512 4da8f66af066ac92b47664d21af34a02526cd1639cb766927670bec0ac8c7416116834c847678a29862a46faeda7e2f2393744be315cdfbbb8bd55a04ceb942c
EBUILD packaging-20.4-r1.ebuild 1403 BLAKE2B 32cdfc7e75e27420dc234bbd1695b21e8b7183941ab590d6eae30d16510d93f323580c19c0ff00da78c6c352e8fd82d610dc6b5bd2f913c7d277c71126b0fc0d SHA512 9aa1b1e682839c0d23f514fd66d9436257b77c2cdcca975106e544ff057d71f84d8c52c8d108d2b996b7341669a07cbf98c64eb37754a6eeae473312d93b5a39
+EBUILD packaging-20.5.ebuild 1012 BLAKE2B 8aaa25b51d42e8ead7aca7ccc20f2fe2f42a00a152bb9cae41a1a724b41af864252e4de09e5a395294dfe6e950a789e06379cf816e2c607687747b1c451103dc SHA512 6f104ac4154b63e8715f44a43be0337e55d565eead686283b795cb5ed66e31ae32607d1039de3116a327ead44575beb22d039f93942ef0adbbda961d6c6ada2a
+EBUILD packaging-20.7.ebuild 1012 BLAKE2B 8aaa25b51d42e8ead7aca7ccc20f2fe2f42a00a152bb9cae41a1a724b41af864252e4de09e5a395294dfe6e950a789e06379cf816e2c607687747b1c451103dc SHA512 6f104ac4154b63e8715f44a43be0337e55d565eead686283b795cb5ed66e31ae32607d1039de3116a327ead44575beb22d039f93942ef0adbbda961d6c6ada2a
MISC metadata.xml 390 BLAKE2B 98afec1f8a7889d12e1a44ef1ff2bf1db635818b7fcb8d86dff0d820fc8fc92920615cd5de63f35cbb6eae6c29f8d6942807f0a7bd48b320c9a0d55a7fa0de69 SHA512 d082f5d387c5d71f0f6cfca4572d4637081daa863186d8b05050738269559617b910c95de97ac3eddd41434cc528e34597125a6973b7b239734c91bb2c588235
diff --git a/dev-python/packaging/packaging-20.5.ebuild b/dev-python/packaging/packaging-20.5.ebuild
new file mode 100644
index 000000000000..6d1b30fa1a72
--- /dev/null
+++ b/dev-python/packaging/packaging-20.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Core utilities for Python packages"
+HOMEPAGE="
+ https://github.com/pypa/packaging/
+ https://pypi.org/project/packaging/"
+SRC_URI="
+ https://github.com/pypa/packaging/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+SLOT="0"
+LICENSE="|| ( Apache-2.0 BSD-2 )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/pyparsing-2.1.10[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ pytest --capture=no --strict -vv || die
+}
diff --git a/dev-python/packaging/packaging-20.7.ebuild b/dev-python/packaging/packaging-20.7.ebuild
new file mode 100644
index 000000000000..6d1b30fa1a72
--- /dev/null
+++ b/dev-python/packaging/packaging-20.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Core utilities for Python packages"
+HOMEPAGE="
+ https://github.com/pypa/packaging/
+ https://pypi.org/project/packaging/"
+SRC_URI="
+ https://github.com/pypa/packaging/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+SLOT="0"
+LICENSE="|| ( Apache-2.0 BSD-2 )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/pyparsing-2.1.10[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ pytest --capture=no --strict -vv || die
+}