summaryrefslogtreecommitdiff
path: root/dev-python/ovs/ovs-2.7.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/ovs/ovs-2.7.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/ovs/ovs-2.7.2.ebuild')
-rw-r--r--dev-python/ovs/ovs-2.7.2.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/ovs/ovs-2.7.2.ebuild b/dev-python/ovs/ovs-2.7.2.ebuild
new file mode 100644
index 000000000000..b0aff0382bd3
--- /dev/null
+++ b/dev-python/ovs/ovs-2.7.2.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="OVS bindings for python."
+HOMEPAGE="https://github.com/openvswitch/ovs/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"