summaryrefslogtreecommitdiff
path: root/dev-python/ovs/ovs-2.13.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-python/ovs/ovs-2.13.3.ebuild
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-python/ovs/ovs-2.13.3.ebuild')
-rw-r--r--dev-python/ovs/ovs-2.13.3.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/ovs/ovs-2.13.3.ebuild b/dev-python/ovs/ovs-2.13.3.ebuild
new file mode 100644
index 000000000000..2d024aad4550
--- /dev/null
+++ b/dev-python/ovs/ovs-2.13.3.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="OVS bindings for python."
+HOMEPAGE="https://github.com/openvswitch/ovs/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+
+RDEPEND="dev-python/sortedcontainers[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"