summaryrefslogtreecommitdiff
path: root/dev-python/overrides/overrides-7.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-07 09:24:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-07 09:24:29 +0100
commitfa77846c708f4d0541b610846a5f2ed14b4b20c1 (patch)
tree35860ca9d75749380daddffe86bbd70d3c5866a9 /dev-python/overrides/overrides-7.4.0.ebuild
parent640c4638f1e12a2c71f539ee18564a0c82d19947 (diff)
gentoo auto-resync : 07:08:2023 - 09:24:28
Diffstat (limited to 'dev-python/overrides/overrides-7.4.0.ebuild')
-rw-r--r--dev-python/overrides/overrides-7.4.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/overrides/overrides-7.4.0.ebuild b/dev-python/overrides/overrides-7.4.0.ebuild
new file mode 100644
index 000000000000..5682e8b4c541
--- /dev/null
+++ b/dev-python/overrides/overrides-7.4.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A decorator to automatically detect mismatch when overriding a method."
+HOMEPAGE="
+ https://pypi.org/project/overrides/
+ https://github.com/mkorpela/overrides/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~s390"
+
+distutils_enable_tests pytest