summaryrefslogtreecommitdiff
path: root/dev-python/outcome
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
commit9aa80713372911cec499b3adb2cd746790920916 (patch)
treeb8e99dc5dd60ac2094a27cc52f74aada8df38f05 /dev-python/outcome
parentb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (diff)
gentoo resync : 29.06.2021
Diffstat (limited to 'dev-python/outcome')
-rw-r--r--dev-python/outcome/Manifest3
-rw-r--r--dev-python/outcome/metadata.xml14
-rw-r--r--dev-python/outcome/outcome-1.1.0.ebuild29
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/outcome/Manifest b/dev-python/outcome/Manifest
new file mode 100644
index 000000000000..5bdf6413d4eb
--- /dev/null
+++ b/dev-python/outcome/Manifest
@@ -0,0 +1,3 @@
+DIST outcome-1.1.0.tar.gz 18675 BLAKE2B eef22274bb4d1ddd19fa223167b6c8ce96f015ac0b3b0609aed3717deb306087457ab068fd2466d492fcc5859d561e6d3172ad14611a937ec59a75b604565953 SHA512 65de1c0a38b8cbb041a9fc3a79518eeacea54ec87341846ae80a9a2075369f72a397f5aa747ae179eaac8f341a7e07cc1641555fbb809cc7924b2171f7f3d90e
+EBUILD outcome-1.1.0.ebuild 715 BLAKE2B f115d97b883b2c313c432d2772b63c64861fadd1f2f84832aed29055f977eb05e839a8f27257e0546f295196b08f3da2f9e40788de9c738f67dfe2c8fcb8e4ff SHA512 a91a46f6022fa56f4b603637de462b34ae1bfd3bdfe26520887593428f1995cf95e7ae5356bdedb51d8f4729399fe42735f888a7b9c293033b73b6d430f802d7
+MISC metadata.xml 412 BLAKE2B a6981a62dd453c13e7568abd6842a1e800ac403566f6a719bde8eb2cf39e85d2d23790af491e44e00219937e8ceabda6203b9a9bb94ace8b42a3b1df9303607c SHA512 ac1240cfa6facb9a0703052eedad4b22c7176a7f1b6b191ddc52b80a9de4087c5edc910cf1c9906f5ffac0d74f4b6fac18cab8c34d5f478ce6146aa78768ad0b
diff --git a/dev-python/outcome/metadata.xml b/dev-python/outcome/metadata.xml
new file mode 100644
index 000000000000..8423947bf6d0
--- /dev/null
+++ b/dev-python/outcome/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">python-trio/outcome</remote-id>
+ <remote-id type="pypi">outcome</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/outcome/outcome-1.1.0.ebuild b/dev-python/outcome/outcome-1.1.0.ebuild
new file mode 100644
index 000000000000..ca48567e6299
--- /dev/null
+++ b/dev-python/outcome/outcome-1.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Capture the outcome of Python function calls"
+HOMEPAGE="
+ https://github.com/python-trio/outcome
+ https://pypi.org/project/outcome
+"
+SRC_URI="https://github.com/python-trio/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/attrs[${PYTHON_USEDEP}]"
+
+BDEPEND="test? (
+ dev-python/async_generator[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/source dev-python/sphinxcontrib-trio