summaryrefslogtreecommitdiff
path: root/dev-python/osrf_pycommon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/osrf_pycommon
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/osrf_pycommon')
-rw-r--r--dev-python/osrf_pycommon/Manifest4
-rw-r--r--dev-python/osrf_pycommon/files/str.patch23
-rw-r--r--dev-python/osrf_pycommon/metadata.xml11
-rw-r--r--dev-python/osrf_pycommon/osrf_pycommon-0.1.10.ebuild28
4 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/osrf_pycommon/Manifest b/dev-python/osrf_pycommon/Manifest
new file mode 100644
index 000000000000..667a69b59ddb
--- /dev/null
+++ b/dev-python/osrf_pycommon/Manifest
@@ -0,0 +1,4 @@
+AUX str.patch 1041 BLAKE2B 35abd358988af1cf45975094758d56648d56cdc302dc507a3e5077e90142d31076d89592a06d1d9eae1dcfdfbc434efbb176990af955c06ce414603cdf7efa62 SHA512 94a8f4d42c3929ca7aa077142c4e5ec91ef2848b6f402b0a9a7beedd96865178ccf431aa8a68cf332927e783e56fdcdf4b8321679c0bdcea4e76564dc7f72d7b
+DIST osrf_pycommon-0.1.10.tar.gz 46303 BLAKE2B 3f18b8683a6363e1f15addfe75b8dee31f64fff7c286379d18355dc1f3467063c2cf1a9eb7978c5f9de5d64cb23d18a3922a416fe24fafa618f50f0ba89cddfe SHA512 5d53ea0c3c410a99964330dc22dcbcb3cd8892a359fee2061acc15ddb46e334ff757e8aa5b776fef381246c58e9834003ac818624da4b8e95552f214f3d9e6bb
+EBUILD osrf_pycommon-0.1.10.ebuild 670 BLAKE2B cdc95910f9bc9a63e53bf3563cd3400def5f8e6e61964fb0e7f1b8e9ba72ea9799cdc10fcbc9251013884d33b79e7af62c2f78037b9a9d8cd25afc491bb4a5c3 SHA512 0a65b2ea65a42944d74630d8e2e98f7e129f6569d0b154a15b9ae485ee4add8142fa1957c3692a49b0bede5012aba6ef64814856cded14c692ca7bace8366c5d
+MISC metadata.xml 332 BLAKE2B 646ed0c829539be3417268e0b8fcffda5a51492f9083d5d20ba037e794b27f54347c8bf5119fc75ddb38760942b8af2ea7d22c379408d02d9e407a9696bf866e SHA512 ae0c307ed8e480f49cb5ba866ad6990fae1feee6bfd6adffa9e1b00d7ff56d8a7acde8e19559a6ea4043f262f8e3cbfa8baa9ad96f053f240694aec3badf56f2
diff --git a/dev-python/osrf_pycommon/files/str.patch b/dev-python/osrf_pycommon/files/str.patch
new file mode 100644
index 000000000000..336813e416fa
--- /dev/null
+++ b/dev-python/osrf_pycommon/files/str.patch
@@ -0,0 +1,23 @@
+From 515fd938513b8e458ce5fb3c937c100a3bc87745 Mon Sep 17 00:00:00 2001
+From: Chris Lalancette <clalancette@openrobotics.org>
+Date: Fri, 19 Jun 2020 17:48:05 -0400
+Subject: [PATCH] Fix the __str__ method for windows terminal_color. (#65)
+
+Signed-off-by: Chris Lalancette <clalancette@openrobotics.org>
+---
+ osrf_pycommon/terminal_color/windows.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/osrf_pycommon/terminal_color/windows.py b/osrf_pycommon/terminal_color/windows.py
+index f0f6120..21f5e8f 100644
+--- a/osrf_pycommon/terminal_color/windows.py
++++ b/osrf_pycommon/terminal_color/windows.py
+@@ -224,7 +224,7 @@ class CONSOLE_SCREEN_BUFFER_INFO(ctypes.Structure):
+
+ def __str__(self):
+ return (
+- '({0}, {0}, {0}, {0}, {0}, {0}, {0}, {0}, {0}, {0}, {0})'
++ '({0}, {1}, {2}, {3}, {4}, {5}, {6}, {7}, {8}, {9}, {10})'
+ .format(
+ self.dwSize.Y, self.dwSize.X,
+ self.dwCursorPosition.Y, self.dwCursorPosition.X,
diff --git a/dev-python/osrf_pycommon/metadata.xml b/dev-python/osrf_pycommon/metadata.xml
new file mode 100644
index 000000000000..b48cc9c2c50e
--- /dev/null
+++ b/dev-python/osrf_pycommon/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">osrf/osrf_pycommon</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/osrf_pycommon/osrf_pycommon-0.1.10.ebuild b/dev-python/osrf_pycommon/osrf_pycommon-0.1.10.ebuild
new file mode 100644
index 000000000000..d38cfc41188e
--- /dev/null
+++ b/dev-python/osrf_pycommon/osrf_pycommon-0.1.10.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{3_7,3_8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Commonly needed Python modules used by Python software developed at OSRF"
+HOMEPAGE="https://github.com/osrf/osrf_pycommon"
+SRC_URI="https://github.com/osrf/osrf_pycommon/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-python/mock[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ test? (
+ dev-python/flake8[${PYTHON_USEDEP}]
+ )
+"
+PATCHES=( "${FILESDIR}/str.patch" )
+
+distutils_enable_tests pytest