summaryrefslogtreecommitdiff
path: root/dev-python/osrf_pycommon/osrf_pycommon-2.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /dev-python/osrf_pycommon/osrf_pycommon-2.0.2.ebuild
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'dev-python/osrf_pycommon/osrf_pycommon-2.0.2.ebuild')
-rw-r--r--dev-python/osrf_pycommon/osrf_pycommon-2.0.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/osrf_pycommon/osrf_pycommon-2.0.2.ebuild b/dev-python/osrf_pycommon/osrf_pycommon-2.0.2.ebuild
new file mode 100644
index 000000000000..b096ab70236b
--- /dev/null
+++ b/dev-python/osrf_pycommon/osrf_pycommon-2.0.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Commonly needed Python modules used by Python software developed at OSRF"
+HOMEPAGE="https://github.com/osrf/osrf_pycommon"
+SRC_URI="https://github.com/osrf/osrf_pycommon/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # linting is something upstreams do
+ # for us, it either means unneeded deps or breakage due to changes
+ tests/test_code_format.py
+)