summaryrefslogtreecommitdiff
path: root/dev-python/oslotest/oslotest-4.5.0-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-22 19:22:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-22 19:22:34 +0100
commitcd18653acd5ce929bb0ec77dde842439db6f060c (patch)
treeb30f926c55ca488ef161aeb8967b1bbc59b31147 /dev-python/oslotest/oslotest-4.5.0-r3.ebuild
parentf29f0d7da5f422c5491502ea0684163fa4471e6b (diff)
gentoo auto-resync : 22:06:2023 - 19:22:34
Diffstat (limited to 'dev-python/oslotest/oslotest-4.5.0-r3.ebuild')
-rw-r--r--dev-python/oslotest/oslotest-4.5.0-r3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/oslotest/oslotest-4.5.0-r3.ebuild b/dev-python/oslotest/oslotest-4.5.0-r3.ebuild
new file mode 100644
index 000000000000..cfdb86d58150
--- /dev/null
+++ b/dev-python/oslotest/oslotest-4.5.0-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Oslo test framework"
+HOMEPAGE="
+ https://opendev.org/openstack/oslotest/
+ https://github.com/openstack/oslotest/
+ https://pypi.org/project/oslotest/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ >=dev-python/pbr-1.8[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-py3.12-fix.patch"
+)
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ sed -i -e '/subunit/d' requirements.txt || die
+ distutils-r1_src_prepare
+}