summaryrefslogtreecommitdiff
path: root/dev-python/oslo-service
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
commit3f71901f8c228f4de570abed1831ce3ee425343e (patch)
treea2dcd300d05ef8a2ec275b44a92a9d85bd3baa24 /dev-python/oslo-service
parent12bb627384ddfd47382b9f1b6464481a58d01ebb (diff)
gentoo resync 08.09.2018
Diffstat (limited to 'dev-python/oslo-service')
-rw-r--r--dev-python/oslo-service/Manifest2
-rw-r--r--dev-python/oslo-service/oslo-service-1.31.3.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/oslo-service/Manifest b/dev-python/oslo-service/Manifest
index e8860605dff0..f458b5394fc8 100644
--- a/dev-python/oslo-service/Manifest
+++ b/dev-python/oslo-service/Manifest
@@ -1,3 +1,5 @@
DIST oslo.service-1.29.0.tar.gz 74957 BLAKE2B b56869cb28704718952c5e151eaf0442b1a4295b8e25a422d91baa241a990d031cd408474e44bd5ea2af2b7451e0c13ec491ed4c2ccf0b07c78b65a81bec4527 SHA512 84f1b8e6abc7c8c95433da53b1a1992570695b80e182f5cb7d87ab394857d8d47c0ef0528b7a45221c897eb4c5c13112d86b8a929efc2988d22844a4c712a340
+DIST oslo.service-1.31.3.tar.gz 71511 BLAKE2B 80cd0824b4e07fe834a41d3918dab2361d9c317a8eec143cf1e3831dbc2fb352c803c7f99fef5047960fc90e3826dbeff7e5f0fc642bc2b58bdfe656bd74925e SHA512 8ddff8c52a3b0eba83c420476d7a420f071d5770b7a9b9e0744a4b9ba216304d81d38268ac0aff889b08572d69d992d883b21df8de6739cba6ddf43ea1563263
EBUILD oslo-service-1.29.0.ebuild 2027 BLAKE2B 5c9eaa83c83e38b744f34bccbde1cf493d3e8a986c52202759913d8c22aa7b2f5879aab02ce695686589159a2ac726ef8c487dfb2a2a30990b311886fe04a2bc SHA512 de0398cc0721e39adb1e20143725fd7d7b113ef11bb41279dead12b1697a4615648d50287fbe6a460306ce1236bce5b013b072a3e0ea695c9b505ee2d4b842e3
+EBUILD oslo-service-1.31.3.ebuild 2122 BLAKE2B 551448d306d33bd3453af9e05f052298de15088f8c684afd8d47f1c20fc3187718408d9237c47efba2631135ebffb4e9b7ab0983127f0558579012bb785527b1 SHA512 06b72e00c96fea378d199f5989eb4bb873d5b4215563cdac91c97d57f3f6e8eb992b0690a0516c2e49ab30e6ce2e9a52fe66fa97153cc3b6f0bbc8f206f62b26
MISC metadata.xml 329 BLAKE2B 2ef43d1bf3df7be8c2e2b08bf7cca10d1bc23235111bc74bf0b23ef6f9c5ac3ad05a1243b518c0d8b703e4815ec7fc92ad01c907baa77d9c4dbb622a1288aaf2 SHA512 c02f0b4e37e3dabe1dbc10ca6b5e08627d8e7df5fee71573cda34338249508586bf068c56711521aa20bf80a1fdcf94a1e89df5d17cb5eb21a07b996a071d1ae
diff --git a/dev-python/oslo-service/oslo-service-1.31.3.ebuild b/dev-python/oslo-service/oslo-service-1.31.3.ebuild
new file mode 100644
index 000000000000..71fb414d08f2
--- /dev/null
+++ b/dev-python/oslo-service/oslo-service-1.31.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for running OpenStack services"
+HOMEPAGE="https://pypi.org/project/oslo.service/"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.service/oslo.service-${PV}.tar.gz"
+S="${WORKDIR}/oslo.service-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/stestr-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.6.6[${PYTHON_USEDEP}]
+ >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
+ >=dev-python/doc8-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ >=dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/webob-1.7.1[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
+ >=dev-python/greenlet-0.4.10[${PYTHON_USEDEP}]
+ >=dev-python/monotonic-0.6[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.25.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/pastedeploy-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/routes-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/paste-2.0.2[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests tests/ || die "test failed under ${EPYTHON}"
+}