summaryrefslogtreecommitdiff
path: root/dev-python/oslo-concurrency
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
commit95461df035e3867364495f065e5e805bf629b2d7 (patch)
tree867dce371a84a696e91be255d89f282975aa0480 /dev-python/oslo-concurrency
parent46eedbedafdb0040c37884982d4c775ce277fb7b (diff)
gentoo resync : 25.10.2021
Diffstat (limited to 'dev-python/oslo-concurrency')
-rw-r--r--dev-python/oslo-concurrency/Manifest2
-rw-r--r--dev-python/oslo-concurrency/oslo-concurrency-4.5.0.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/oslo-concurrency/Manifest b/dev-python/oslo-concurrency/Manifest
index b07068f69720..bd2eac2afd6b 100644
--- a/dev-python/oslo-concurrency/Manifest
+++ b/dev-python/oslo-concurrency/Manifest
@@ -1,3 +1,5 @@
DIST oslo.concurrency-4.4.1.tar.gz 58399 BLAKE2B ea28cdd53ae124fe458c0d901b305d99b7a5b5525835e6a04ca856177876fa6c6a1eff74842dcf260c78c205d95f353cd1b70f0cb6205e7bec841bae2d6ecd0d SHA512 1b7e6a2cb2e3ee0710f652489522c7a9e47a5292c46041f21a2ffe4c61a6bbae48b43e93507465013704b89778deec860da06fec32b4d3778e05cade9a6d39a1
+DIST oslo.concurrency-4.5.0.tar.gz 58979 BLAKE2B 9e2eb4a233985a33994aeaf335c195c980e1e9dd8b48a7c4e53ae502599f12c0dc65466ee45569a97b72f1face0e80ce166922ca3e42f6ad28fd5b27bdf884a3 SHA512 13a2f4d39d3241370374e6fe4ea6047dfc4d20da6116aaebd27f085fdbce089d58b0ebab4f1224234c88237cdefafc2f96229e6527bf5cda13ef1e471e25a50c
EBUILD oslo-concurrency-4.4.1.ebuild 942 BLAKE2B c3887289a90a3995134f1ed05fe94ee06ec680181dcb08f3c9f67286613ea019b8e213db6b04b824ce41def70dbdb588fa6722abfbbcde18cdcdb26776a4f599 SHA512 7da4b3cf75c8ce9b8f626790ccf1a4dce04b4f80290064ba69cc8e5179527dd8a382b65585a4471f751bdc3fe73df4c17a697a82d53f462ebd0be3f71fde9b9c
+EBUILD oslo-concurrency-4.5.0.ebuild 942 BLAKE2B c3887289a90a3995134f1ed05fe94ee06ec680181dcb08f3c9f67286613ea019b8e213db6b04b824ce41def70dbdb588fa6722abfbbcde18cdcdb26776a4f599 SHA512 7da4b3cf75c8ce9b8f626790ccf1a4dce04b4f80290064ba69cc8e5179527dd8a382b65585a4471f751bdc3fe73df4c17a697a82d53f462ebd0be3f71fde9b9c
MISC metadata.xml 539 BLAKE2B 243e21ae592bc6063b27bd2da21e7c9b7caf5127ecfa616dac4e36f34a74c0a8d221a83659596faaf5981451feb79553f4dfb94dbdd35916dafc32c5c6d6f279 SHA512 5d1bdc934197cf39dda7e8b14d573c7e401c4b18c09da4447e1ab0ec97fff0f24f90908819a0a3e03956bcdcd58af9beb95511346346c29d59eea8f752751a1b
diff --git a/dev-python/oslo-concurrency/oslo-concurrency-4.5.0.ebuild b/dev-python/oslo-concurrency/oslo-concurrency-4.5.0.ebuild
new file mode 100644
index 000000000000..6ee2324081d6
--- /dev/null
+++ b/dev-python/oslo-concurrency/oslo-concurrency-4.5.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Oslo Concurrency library"
+HOMEPAGE="https://pypi.org/project/oslo.concurrency/ https://github.com/openstack/oslo.concurrency"
+SRC_URI="mirror://pypi/o/${PN/-/.}/${PN/-/.}-${PV}.tar.gz"
+S="${WORKDIR}/${PN/-/.}-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/fasteners-0.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND=">dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.19.0[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest