summaryrefslogtreecommitdiff
path: root/dev-python/oslo-concurrency
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
commit391b5b359a346aff490103da7dddc85047f83830 (patch)
tree29eea460a0bd7e1ff21d43b9d6df9af4d8a175e1 /dev-python/oslo-concurrency
parentc719fdcee603a5a706a45d10cb598762d56a727d (diff)
gentoo resync : 01.10.2021
Diffstat (limited to 'dev-python/oslo-concurrency')
-rw-r--r--dev-python/oslo-concurrency/Manifest3
-rw-r--r--dev-python/oslo-concurrency/metadata.xml17
-rw-r--r--dev-python/oslo-concurrency/oslo-concurrency-4.4.1.ebuild32
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/oslo-concurrency/Manifest b/dev-python/oslo-concurrency/Manifest
new file mode 100644
index 000000000000..bf43a71b0370
--- /dev/null
+++ b/dev-python/oslo-concurrency/Manifest
@@ -0,0 +1,3 @@
+DIST oslo.concurrency-4.4.1.tar.gz 58399 BLAKE2B ea28cdd53ae124fe458c0d901b305d99b7a5b5525835e6a04ca856177876fa6c6a1eff74842dcf260c78c205d95f353cd1b70f0cb6205e7bec841bae2d6ecd0d SHA512 1b7e6a2cb2e3ee0710f652489522c7a9e47a5292c46041f21a2ffe4c61a6bbae48b43e93507465013704b89778deec860da06fec32b4d3778e05cade9a6d39a1
+EBUILD oslo-concurrency-4.4.1.ebuild 937 BLAKE2B c2eb9d0b1292d0c2de0f2d28a7af15604bac6ac58440c9214711dada90f0dd085e663052837fb196add0f1fd6b7c867878bb2b9e6401030d9529f138959f5cd9 SHA512 7863eb4344bdecbd0011b00fd2a7150d14b83df073e6998ae3fb996537b090d79094172933cac41ea961ce1d765c5bf9498a7e412c4d1334da24afd98d536102
+MISC metadata.xml 539 BLAKE2B 243e21ae592bc6063b27bd2da21e7c9b7caf5127ecfa616dac4e36f34a74c0a8d221a83659596faaf5981451feb79553f4dfb94dbdd35916dafc32c5c6d6f279 SHA512 5d1bdc934197cf39dda7e8b14d573c7e401c4b18c09da4447e1ab0ec97fff0f24f90908819a0a3e03956bcdcd58af9beb95511346346c29d59eea8f752751a1b
diff --git a/dev-python/oslo-concurrency/metadata.xml b/dev-python/oslo-concurrency/metadata.xml
new file mode 100644
index 000000000000..19a76ec7391d
--- /dev/null
+++ b/dev-python/oslo-concurrency/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>arthurzam@gentoo.org</email>
+ <name>Arthur Zamarin</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">oslo.concurrency</remote-id>
+ <remote-id type="github">openstack/oslo.concurrency</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/oslo-concurrency/oslo-concurrency-4.4.1.ebuild b/dev-python/oslo-concurrency/oslo-concurrency-4.4.1.ebuild
new file mode 100644
index 000000000000..1d4915b303dc
--- /dev/null
+++ b/dev-python/oslo-concurrency/oslo-concurrency-4.4.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Oslo Concurrency library"
+HOMEPAGE="https://pypi.org/project/oslo.concurrency/ https://github.com/openstack/oslo.concurrency"
+SRC_URI="mirror://pypi/o/${PN/-/.}/${PN/-/.}-${PV}.tar.gz"
+S="${WORKDIR}/${PN/-/.}-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/fasteners-0.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND=">dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.19.0[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest