summaryrefslogtreecommitdiff
path: root/dev-python/oslo-cache
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-22 10:09:44 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-22 10:09:44 +0000
commit09351e78166b5e864197c4456ebae3f89dd0bed9 (patch)
tree41a96399f56ed3aa399006871bfce4430db84aa2 /dev-python/oslo-cache
parentc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (diff)
gentoo resync : 22.01.2019
Diffstat (limited to 'dev-python/oslo-cache')
-rw-r--r--dev-python/oslo-cache/Manifest2
-rw-r--r--dev-python/oslo-cache/oslo-cache-1.30.1.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/oslo-cache/Manifest b/dev-python/oslo-cache/Manifest
index e9dd3189ffc7..002866209cc7 100644
--- a/dev-python/oslo-cache/Manifest
+++ b/dev-python/oslo-cache/Manifest
@@ -1,3 +1,5 @@
DIST oslo-cache-1.28.0.tar.gz 52015 BLAKE2B 897e54008ea99f367f373291d874736287dfd3d480046bdee0ab2b54969e8681144677713794ff32682b1ef65547618d5fcf403e9ae24b57768905daf7ae7f5e SHA512 44deabf9dbe3c24afd04d09f91f95d902221995130559e7895045eed98356ed9e085f5ee9b7e2bd0b4581df563a67707121b7571b0b7f822f0bb5a55b6dedafe
+DIST oslo-cache-1.30.1.tar.gz 53406 BLAKE2B 1b518c7f7af4b95fc71f76567f8742de7c7ab520cf4a1943fc7ed7bd9f3dcfd4150f83774e507d4135c7b567e53c3beb79a0cf6295c23e23d88a49d9ce63d2ed SHA512 8ee8ef32d07e8112aa7280f541446d13b3bba90fc7314eee60972180b0382a413e02cfcffbdd5bf4313aa394a25265665579f43f702a4b3754dc00f50441ca38
EBUILD oslo-cache-1.28.0.ebuild 1045 BLAKE2B 5a476016a4a20177ffdafa93bd970a2da0e87fa07a50b7ee493f5a3292f66a727849f33fbae9dbc2d5b36d6b2bf8727d8d75e7be82e25cf331d7349cf1fe0746 SHA512 6b2078d289a99f5fd9db6c7c658064ebcea2cceff76ffe6572e1a44fbe31873378b99450274f431b162e5de8bb5c329707036aef50f3fff871b2a05cc7210495
+EBUILD oslo-cache-1.30.1.ebuild 1044 BLAKE2B 79d39645f2b468e0d1329808882ae4b62acea6eb3fcf7aa2ba205d6892c25c8cc0aae7117bda7798d06d036e5047a0025c38a518769e2c3592b09b328b9d8e4c SHA512 d0a630a8c4426db273533583efeff4590fb8eea5339075484002418d2c85b71f02a0caa21e1af7e1071c279400eaf34184a6f95705dd4c1c8fa02c902533edc5
MISC metadata.xml 457 BLAKE2B 09e44ecf9952f5bfd930616506874014a267d8622daf6c22b3da4856d9f4bbedcb3e4e72285972da026f310c47973c0bb70c222292caf877d4f9ab6d5166955a SHA512 f98547e9de8c502afabf7c53409df90ec687159b5160c8ff2166acff4d6bce0fe69c8eec78d50f52919cd75733f44f82dea5f9cde362d22ed69200d332b9d6b7
diff --git a/dev-python/oslo-cache/oslo-cache-1.30.1.ebuild b/dev-python/oslo-cache/oslo-cache-1.30.1.ebuild
new file mode 100644
index 000000000000..71b251dd4d54
--- /dev/null
+++ b/dev-python/oslo-cache/oslo-cache-1.30.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1 vcs-snapshot
+
+MY_PN=${PN/-/.}
+
+DESCRIPTION="Oslo Caching around dogpile.cache"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/dogpile-cache-0.6.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.30.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.31.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}