summaryrefslogtreecommitdiff
path: root/dev-python/os-win
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/os-win
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/os-win')
-rw-r--r--dev-python/os-win/Manifest4
-rw-r--r--dev-python/os-win/metadata.xml1
-rw-r--r--dev-python/os-win/os-win-5.1.0.ebuild34
3 files changed, 38 insertions, 1 deletions
diff --git a/dev-python/os-win/Manifest b/dev-python/os-win/Manifest
index 331573a60dbe..eeb4018d1ecb 100644
--- a/dev-python/os-win/Manifest
+++ b/dev-python/os-win/Manifest
@@ -1,3 +1,5 @@
DIST os-win-4.2.0.tar.gz 214676 BLAKE2B 689417494acd7ddf219b7b29d670ed888dc0649fddb5e0a94b5160b2bec66167c14a315e0daa2f0fa794de96cecb15a054cbc6f4df0c4c8d26abb2367eb06862 SHA512 5f828e5b0b0a178a65959bb69f88c7bf30282b71f458ac36c11ef197dac3e821a2cbfb8be43acbc90d845e247be990ce6618b6dbe60205af8e890c2f7b7d245e
+DIST os-win-5.1.0.tar.gz 221803 BLAKE2B 37fa5271b86f62a43ea1f6da011601260a9cd32745a2369093dc5103e54945c17d16ecfaf8f5d88fd7ec3673ac41e25ff02d3c15ec5423fb9651101213801cab SHA512 bb93af1b412b8e0699f62a772bf9bacc73e2e73751cf0e9b9a37d59869a6c31e39ddbaafc4b97b494d9a38208d765362a6ce7fe071e1c089c127e1554ae73a02
EBUILD os-win-4.2.0.ebuild 1147 BLAKE2B 4d3adc4ba3384bf76908f3aee30215edeae575dd67da0e34d3d2da2ee9304e77ba048c2e3b36e45fcfa8c38150a181107079998ba46c0816e05a3859f5c4cafb SHA512 069e3aee3752de235b9033c7ede59bed73dbbb5f45b0e67f44bff5787bbea5ee1f82ed7c62dc203df288306959fc07c80fec2a3645a036f3fc0ccbdae1ac5e24
-MISC metadata.xml 379 BLAKE2B 221fd31006c800565bbed8c644064d4ce7a310d462c54c58bbd71675953d08fca725f5e0ce545f99fd96ad6dd0043956c5654b76c13088063ed0a15e59e0d54f SHA512 f52b0f9667e80279be3ee42df1bdaec3c8f9952ebe7b166b2fe7c2bc10017ba29833b50072d9f42bf1950d3c9a2e8e72d476c24aa51b2efe308ad55501df60ed
+EBUILD os-win-5.1.0.ebuild 1028 BLAKE2B 1a0c9cba98bfe2dd76862235f1109a6cabc6958ff012f28c439b6a208422e5700dfeb9ac12508632941634496b8098dec2cdbdcc987fdea09dd4d4222d0bc625 SHA512 0a57d2b500bf772a337ee9025e8cca6c1e9269a7ee57677417a09e4131f08b719cd856ad68c66e80343d826b54cfa02d8e11e5c0f9176aeea608b7f26f199a52
+MISC metadata.xml 403 BLAKE2B b1291890c4b8c356636422394b5726535319779de643865c197892f38ca4ffcd6a3a916844582e197cd9b9faee095f08c7972b96ce2c4fcfb4faf2d1bc799677 SHA512 cf4fd600f51cce0d2466879d7f417502ea45a96669544d5eb50fed828a36a60edc00ff9ea11c9beb445cfa29174c9782fa0f27369dc4b3f9a5d41ac2db46543d
diff --git a/dev-python/os-win/metadata.xml b/dev-python/os-win/metadata.xml
index c763b6a4b983..3d5c5ce2e13f 100644
--- a/dev-python/os-win/metadata.xml
+++ b/dev-python/os-win/metadata.xml
@@ -5,6 +5,7 @@
<email>prometheanfire@gentoo.org</email>
<name>Matthew Thode</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="github">openstack/os-win</remote-id>
<remote-id type="pypi">os-win</remote-id>
diff --git a/dev-python/os-win/os-win-5.1.0.ebuild b/dev-python/os-win/os-win-5.1.0.ebuild
new file mode 100644
index 000000000000..994447a0d096
--- /dev/null
+++ b/dev-python/os-win/os-win-5.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Windows / Hyper-V library for OpenStack projects."
+HOMEPAGE="https://github.com/openstack/os-win"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+"